Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarked item stays in home page seach bar. Won't clear. How Fix?

  • 13 replies
  • 1 has this problem
  • 119 views
  • Last reply by cor-el

more options

On the Firefox home page search box one of my bookmarks has suddenly appeared there in grey. It can not be deleted in the usual ways (highlight/delete, backspace over, etc.) but if something is typed it disappears. BUT, when Search is activated the search goes to the search on the bookmark item's page!

Reloaded, restart, shut down restart have not worked. How to fix?

Chosen solution

Just change the search engine that is selected in the Search Bar.

Read this answer in context 👍 0

All Replies (13)

more options

What is your home page?

Are you talking about the about:newtab page with the 3 rows and 3 columns of thumbnails?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

You can use the SearchReset extension to reset some preferences to the default values.

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

more options

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

more options

Here's the screen shot.

more options

A new feature in Firefox 23 is that all 3 search boxes (Location Bar, the about:home Search Container, and the Search Bar) are connected the the Search Engine which is selected in the Search Bar. That AddALL new appears to be a search engine, not a Bookmark; that Search plugin is available from here - http://www.addall.com/Plugin/newhelp.html

more options

And when I installed that AddALL search plugin, it appeared in the about:home Search Container when that Search Engine was selected in the Search Bar, just as in your screenshot.

more options

That help page looks largely outdated: Modified: Sun, 20 Sep 2009 03:47:21 GMT

I keep the snippets disabled (browser.aboutHomeSnippets.updateUrl = ""), so I not not confronted with such 'offers'.

more options

You are all speaking tech to a non- technical user This has always been my Firefox home or opening page. I have no clue how that got there. I do not want every search term I enter sent to Addall for a book search! I just want it off.

more options

Chosen Solution

Just change the search engine that is selected in the Search Bar.

more options

Thank you. How?

more options

I found "restart with add-ons disabled". Is that what I should do?

more options

See:

The search engine that is used on the location bar and on the about:home page is the search engine that is selected in the search Bar on the Navigation Toolbar.
You can install the Keyword Search extension to specify with search engine to use for the location bar and which search engine to use for the about:home page via the Options/Preferences windows of this extension, accessible via the about:addons page.

more options

Thank you so much. Nothing I had ever noticed or used before. And I've not a clue how Addall got there! But, Firefox has been glitchy lately. Again Thanks.

more options

You're welcome