X
Tap here to go to the mobile version of the site.

Support Forum

How do I get Firefox to display the full URI in the address bar?

Posted

I've seen this answer, but it doesn't fully fix the problem: https://support.mozilla.org/en-US/questions/951487

When I look at the address bar, I want to see the actual URI of the page I'm on, not some mangled version of it. In other words, I want to see the address in the form that is valid in an <a/> tag in XHTML.

Setting browser.urlbar.trimURLs to false fixes HALF of the problem, but not all of it. If I type in "http://example.com/filename%20with%20spaces.ext", I should see "http://example.com/filename%20with%20spaces.ext". However, I instead see "http://example.com/filename with spaces.ext". The "%20"s are converted into spaces, which are not valid in a real URI. How do I fix the address bar to show the real address of the page?

EDIT: It seems to me that if someone sets the trim setting to false, the URI should not be trimmed in ANY way. This includes the shortening of %20 to a space character. Is this a bug?

I've seen this answer, but it doesn't fully fix the problem: https://support.mozilla.org/en-US/questions/951487 When I look at the address bar, I want to see the actual URI of the page I'm on, not some mangled version of it. In other words, I want to see the address in the form that is valid in an <a/> tag in XHTML. Setting browser.urlbar.trimURLs to false fixes HALF of the problem, but not all of it. If I type in "http://example.com/filename%20with%20spaces.ext", I should see "http://example.com/filename%20with%20spaces.ext". However, I instead see "http://example.com/filename with spaces.ext". The "%20"s are converted into spaces, which are not valid in a real URI. How do I fix the address bar to show the real address of the page? EDIT: It seems to me that if someone sets the trim setting to false, the URI should not be trimmed in ANY way. This includes the shortening of %20 to a space character. Is this a bug?

Modified by 0gb.us

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.2 r202

Application

  • User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:21.0) Gecko/20100101 Firefox/21.0

More Information

jscher2000
  • Top 10 Contributor
8703 solutions 71122 answers

Hi mrphuntt, can you see the "domain" part of the URL?

Firefox leaves the domain in regular black type but makes the rest of the URL gray, the idea being that you can then more quickly verify that it's the actual site you want to be on. But depending on your theme or color scheme, this might make the rest of the URL too faint. You can adjust a setting to make the URL appear all in black type.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box that appears above the list, type or paste urlbar and pause while the list is filtered

(3) Double-click browser.urlbar.formatting.enabled to switch it from its value from true (the default) to false. If you click another tab, is the URL more visible?


If you can't see any of it, perhaps you are using an incompatible theme or extension. Over the years, several extensions have caused this problem until they were updated. You could try updating your extensions, and/or try Firefox's Safe Mode using the default theme and having your extensions disabled to see whether that makes a difference. For advice on particular themse or extensions, it's easiest to start a new question, where you can more easily include that list.

  • To update extensions:

orange Firefox button (or Tools menu) > Add-ons > "gear" button > "Check for Updates"

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Hi mrphuntt, can you see the "domain" part of the URL? Firefox leaves the domain in regular black type but makes the rest of the URL gray, the idea being that you can then more quickly verify that it's the actual site you want to be on. But depending on your theme or color scheme, this might make the rest of the URL too faint. You can adjust a setting to make the URL appear all in black type. (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter. Click the button promising to be careful. (2) In the search box that appears above the list, type or paste '''urlbar''' and pause while the list is filtered (3) Double-click '''browser.urlbar.formatting.enabled''' to switch it from its value from true (the default) to false. If you click another tab, is the URL more visible? ---- If you can't see any of it, perhaps you are using an incompatible theme or extension. Over the years, several extensions have caused this problem until they were updated. You could try updating your extensions, and/or try Firefox's Safe Mode using the default theme and having your extensions disabled to see whether that makes a difference. For advice on particular themse or extensions, it's easiest to start a new question, where you can more easily include that list. * To update extensions: orange Firefox button (or Tools menu) > Add-ons > "gear" button > "Check for Updates" * Firefox's Safe Mode is a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) * To start a new question: https://support.mozilla.org/en-US/questions/new/desktop/fix-problems
mrphuntt 0 solutions 3 answers

Your instructions did the trick and when I toggled to a "false" formatting setting, that change now allows me to see the URL in the Address box.

Thanks for helping out on that!

Your instructions did the trick and when I toggled to a "false" formatting setting, that change now allows me to see the URL in the Address box. Thanks for helping out on that!

Question owner

This doesn't fix the problem that the initial post is about. This changes the false URI from being a mix of grey and black to being just black, but the initial post is about the fact that URI-encoded (%-encoded) characters are incorrectly displayed decoded. FOr example, "%20" in a URI should display as just that: "%20". Instead, it displays as " ".

This doesn't fix the problem that the initial post is about. This changes the false URI from being a mix of grey and black to being just black, but the initial post is about the fact that URI-encoded (%-encoded) characters are incorrectly displayed decoded. FOr example, "%20" in a URI should display as just that: "%20". Instead, it displays as " ".
jscher2000
  • Top 10 Contributor
8703 solutions 71122 answers

Hi 0gb.us, you're right. Do you have the options to remove the "solution" designation from that post if you check to the right of it? If you don't, a moderator might be able to do it. (I'm not a moderator and don't know the details.)

Hi 0gb.us, you're right. Do you have the options to remove the "solution" designation from [https://support.mozilla.org/en-US/questions/961465?page=2#answer-485924 that post] if you check to the right of it? If you don't, a moderator might be able to do it. (I'm not a moderator and don't know the details.)
mrphuntt 0 solutions 3 answers

My apologies for possibly taking this series off target. I can see that the information that I used to solve my issue didn't solve the original issue the 0gb.us had.

My apologies for possibly taking this series off target. I can see that the information that I used to solve my issue didn't solve the original issue the 0gb.us had.

Question owner

Okay, I see the option. Thanks!

No worries, no harm done. I just kind of panicked a little when I saw this question marked as solved. This seems like a serous bug and I didn't want it to be overlooked simply because it had been prematurely marked as solved.

Okay, I see the option. Thanks! No worries, no harm done. I just kind of panicked a little when I saw this question marked as solved. This seems like a serous bug and I didn't want it to be overlooked simply because it had been prematurely marked as solved.
cor-el
  • Top 10 Contributor
  • Moderator
17483 solutions 157999 answers

OK, I've removed the solution from [/questions/961465?page=2#answer-485924]

OK, I've removed the solution from [[/questions/961465?page=2#answer-485924]]