X
Tap here to go to the mobile version of the site.

Support Forum

How do I turn off notifications that keep interrupting my work!?

Posted

Firefox 20.0 has added an infuriating feature that causes notification windows to pop up alerting me to whatever it feels like whenever it feels like. This telemarketing-style interruption is absolutely pointless and 100% in my way, and there HAS to be a way to disable it. Please, someone help! I don't want to have to drop Firefox—I've dealt with all kinds of ridiculous changes over the years—but I can't live with these interruptions.

I'm using Mac OS X 10.8.2.

Also, if anyone knows how to turn off that animated downloading arrow, that would be great, too.

Firefox 20.0 has added an infuriating feature that causes notification windows to pop up alerting me to whatever it feels like whenever it feels like. This telemarketing-style interruption is absolutely pointless and 100% in my way, and there HAS to be a way to disable it. Please, someone help! I don't want to have to drop Firefox—I've dealt with all kinds of ridiculous changes over the years—but I can't live with these interruptions. I'm using Mac OS X 10.8.2. Also, if anyone knows how to turn off that animated downloading arrow, that would be great, too.

Additional System Details

Installed Plug-ins

  • Shockwave Flash 11.6 r602
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • A plugin to detect whether the Adobe Application Manager is installed on this machine.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • iPhoto6
  • Displays Java applet content, or a placeholder if Java is not installed.
  • 5.1.10411.0

Application

  • User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.8; rv:20.0) Gecko/20100101 Firefox/20.0

More Information

philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23463 answers

hello, this sounds like a problem possibly caused by malware on your system. please go to firefox > addons > extensions & remove any suspicious entries (toolbars, things that you have not installed intentionally, don't know what purpose they serve, etc).

Remove a toolbar that has taken over your Firefox search or home page Troubleshoot Firefox issues caused by malware

hello, this sounds like a problem possibly caused by malware on your system. please go to ''firefox > addons > extensions'' & remove any suspicious entries (toolbars, things that you have not installed intentionally, don't know what purpose they serve, etc). [[Remove a toolbar that has taken over your Firefox search or home page]] [[Troubleshoot Firefox issues caused by malware]]
John99 971 solutions 13138 answers

There are other posts about the new download feature. I am more interested initially in your primary point and am wondering what you have installed or are using.

It is not the social / facebook feature introduced last year is it ?

Otherwise it is likely some sort of adware that you have on your computer.


P.S. a screenshot may help

There are other posts about the new download feature. I am more interested initially in your primary point and am wondering what you have installed or are using. It is not the social / facebook feature introduced last year is it ? * https://blog.mozilla.org/futurereleases/2012/07/06/bringing-social-to-firefox/ *https://blog.mozilla.org/press/2012/12/firefox-gets-social-with-facebook/ Otherwise it is likely some sort of adware that you have on your computer. ---- P.S. a screenshot may help * [[How do I create a screenshot of my problem?]]

Modified by John99

Question owner

It isn't malware, nor is it unrelated to Firefox. There is an Apple Notification feature, but this is unrelated, as I've completely disabled that application. I first had the problem in Aurora, a version of Firefox. After an upgrade, notifications began to pop up in the upper right hand corner telling me absolutely pointless things, such as that there's an update available for Aurora. I switched back to Firefox, it did an automatic upgrade, and the same problem has surfaced again here.

I'll try to get a screen shot of it.

It isn't malware, nor is it unrelated to Firefox. There is an Apple Notification feature, but this is unrelated, as I've completely disabled that application. I first had the problem in Aurora, a version of Firefox. After an upgrade, notifications began to pop up in the upper right hand corner telling me absolutely pointless things, such as that there's an update available for Aurora. I switched back to Firefox, it did an automatic upgrade, and the same problem has surfaced again here. I'll try to get a screen shot of it.
John99 971 solutions 13138 answers

I use Aurora, that will update a lot more frequently than ordinary releases, but not as often as Nightlies.

I use Linux most of the time, and am not sure what is normal for a Mac. What notifications do you get besides those saying Firefox |Aurora is updating ?

I use Aurora, that will update a lot more frequently than ordinary releases, but not as often as Nightlies. I use Linux most of the time, and am not sure what is normal for a Mac. What notifications do you get besides those saying Firefox |Aurora is updating ?
srseale 0 solutions 5 answers

Hi John, I have these pop-up notifications from Facebook when using Firefox, and I HATE them. They interfere with my work and they take up space where I can't get to my tabs. If I want to know what's going on in FB I will go to FB. How do I turn this off? If Firefox has built this feature without a way to turn it off, then I will abandon Firefox in preference of Google Chrome. Please reply.

Hi John, I have these pop-up notifications from Facebook when using Firefox, and I HATE them. They interfere with my work and they take up space where I can't get to my tabs. If I want to know what's going on in FB I will go to FB. How do I turn this off? If Firefox has built this feature without a way to turn it off, then I will abandon Firefox in preference of Google Chrome. Please reply.
the-edmeister
  • Top 25 Contributor
  • Moderator
5406 solutions 40227 answers

"Social" is turned off by default, the user needs to turn it on.

As requested by John99 to the original poster, please provide a screenshot of that message.

"Social" is turned off by default, the user needs to turn it on. As requested by John99 to the original poster, please provide a screenshot of that message.
srseale 0 solutions 5 answers

I never turned anything on. How do I turn "Social" off? I Hate the facebook pop up notifications and I really want them gone!

I never turned anything on. How do I turn "Social" off? I Hate the facebook pop up notifications and I really want them gone!
Tyler Downer
  • Top 25 Contributor
  • Moderator
1535 solutions 10701 answers

Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!

Hello, In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see [[How do I create a screenshot of my problem?]] Once you've done this, attach the saved screenshot file to your forum post by clicking the '''Browse...''' button below the ''Post your reply'' box. This will help us to visualize the problem. Thank you!
srseale 0 solutions 5 answers

Attached is a screenshot. Keep in mind, that these notifications pop up whether or not I have Facebook open in the browser, or even if I'm logged out of FB! What can I do to stop them? Your help is appreciated.... Shelley

Attached is a screenshot. Keep in mind, that these notifications pop up whether or not I have Facebook open in the browser, or even if I'm logged out of FB! What can I do to stop them? Your help is appreciated.... Shelley
philipp
  • Top 25 Contributor
  • Moderator
5315 solutions 23463 answers

hello srseale, i'm no facebook user myself, but first please see if there's the option to switch off these kind of notifications in the website's preferences...

if this doesn't work or isn't available try this: enter about:config into the firefox address bar (confirm the info message in case it shows up) & search for the preference named dom.webnotifications.enabled. double-click it and change its value to false.

hello srseale, i'm no facebook user myself, but first please see if there's the option to switch off these kind of notifications in the website's preferences... if this doesn't work or isn't available try this: enter '''about:config''' into the firefox address bar (confirm the info message in case it shows up) & search for the preference named '''dom.webnotifications.enabled'''. double-click it and change its value to '''false'''.
cor-el
  • Top 10 Contributor
  • Moderator
17524 solutions 158458 answers

You can disable the Social features by setting the social.enabled pref to false on the about:config page.

You can disable the Social features by setting the <b>social.enabled</b> pref to false on the <b>about:config</b> page. *http://kb.mozillazine.org/about:config
srseale 0 solutions 5 answers

I have tried this, but there is no dom.webnotifications.enabled in my config file.

I have tried this, but there is no dom.webnotifications.enabled in my config file.
srseale 0 solutions 5 answers

Cor-el, my social.enabled is already false. See screenshot. Still cannot figure out why I am getting these pop up notifications. It is definitely NOT in Facebook, because it only happens in Firefox. Does not happen with Chrome or Safari, so it's clearly a Firefox issue.

Cor-el, my social.enabled is already false. See screenshot. Still cannot figure out why I am getting these pop up notifications. It is definitely NOT in Facebook, because it only happens in Firefox. Does not happen with Chrome or Safari, so it's clearly a Firefox issue.
cor-el
  • Top 10 Contributor
  • Moderator
17524 solutions 158458 answers

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Firefox uses the about: protocol to access built-in about: pages that you can open via the location bar just like you open web pages.

Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Firefox uses the about: protocol to access built-in about: pages that you can open via the location bar just like you open web pages. *http://kb.mozillazine.org/About_protocol_links). *Do NOT click the Reset button on the Safe Mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
dldonart 0 solutions 1 answers

Helpful Reply

I had the same problem after the last update (Firefox 22). Firefox would show a notification after completing a download. I don't know why the developers would begin such a feature without providing a way to disable in preferences. Anyhow, my solution was to go into about:config and change browser.download.manager.showAlertOnComplete from true to false.

I think this may be a solution for the OP. The conversation seems to have gotten sidetracked to the social feature, but SunSpirit13 also mentions the download arrow, which makes me think s(he) was referring to download alerts.

I had the same problem after the last update (Firefox 22). Firefox would show a notification after completing a download. I don't know why the developers would begin such a feature without providing a way to disable in preferences. Anyhow, my solution was to go into about:config and change '''browser.download.manager.showAlertOnComplete''' from true to false. I think this may be a solution for the OP. The conversation seems to have gotten sidetracked to the social feature, but SunSpirit13 also mentions the download arrow, which makes me think s(he) was referring to download alerts.

Modified by dldonart

vg513 0 solutions 1 answers

I started seeing growl-like notifications on OS X after literally doing nothing but restarting Firefox. It looks like a plug-in I have is generating them, but IMO there should be a well-known central location for managing such things (think iOS acting as an intermediary between the system and applications).

I also cannot find a way to turn off the plug-in notifications, although I did disable the download ones using about:config as mentioned by didonart above.

If I have taken no action, I should not see things that pop up and distract me!

I started seeing growl-like notifications on OS X after literally doing nothing but restarting Firefox. It looks like a plug-in I have is generating them, but IMO there should be a well-known central location for managing such things (think iOS acting as an intermediary between the system and applications). I also cannot find a way to turn off the plug-in notifications, although I did disable the download ones using about:config as mentioned by didonart above. If I have taken no action, I should not see things that pop up and distract me!
anuswara 4 solutions 195 answers

I hate this plugin notification: how to do? have I to change some keys in about:config?

or Mozilla encourages users to give up using the very good noscript?

astonished.

I hate this plugin notification: how to do? have I to change some keys in about:config? or Mozilla encourages users to give up using the very good noscript? astonished.
AliceWyman
  • Moderator
240 solutions 2597 answers

anuswara, You have replied to a 5-month old question originally posted April 27, 2013. See Forum rules and guidelines: For support requests, do not re-use existing threads started by others, even if they are seemingly on the same subject. You can ask your own question on the support forum by starting here: https://support.mozilla.org/questions/new

SunSpirit13, You never got back to us after you wrote on April 27th that you would try to get a screenshot of the Firefox notifications that are interrupting your work. If you still need help with this problem, please reply within the month as threads are automatically closed to further replies after 180 days have passed since the original question.

'''anuswara,''' You have replied to a 5-month old question originally posted April 27, 2013. See [[Forum rules and guidelines]]: ''For support requests, do not re-use existing threads started by others, even if they are seemingly on the same subject.'' You can ask your own question on the support forum by starting here: https://support.mozilla.org/questions/new '''SunSpirit13''', You never got back to us after you wrote on April 27th that you would try to get a screenshot of the Firefox notifications that are interrupting your work. If you still need help with this problem, please reply within the month as threads are automatically closed to further replies after 180 days have passed since the original question.
John99 971 solutions 13138 answers

I will lock this thread it was started months ago relating to Firefox 20 and seems to cover multiple subjects. The current Release is Firefox 24.

Please start your own thread about your own problem by asking a new question.

Note forum guidelines do ask you to start new questions and not add to another persons question even if it is the same subject.

<s>I will lock this thread </s>it was started months ago relating to Firefox 20 and seems to cover multiple subjects. The current Release is Firefox 24. Please start your own thread about your own problem by asking a new question. * Please use [/questions/new/] Note forum [[Forum rules and guidelines| guidelines]] do ask you to start new questions and not add to another persons question even if it is the same subject.

Modified by John99