X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

re-downloaded because it wasn't accessing the web, and it still isn't. Opens in Private Browsing, no Firefox tab is visible, so I can't do anything.

Posted

I don't remember choosing Private Browsing before I removed Firefox from my computer. After downloading from the website, the same screen appears. It doesn't look like the website displays it. I have a screenshot but don't see a way to attach it here. The top line is blue Windows background and says "Mozilla Firefox Start Page - Mozilla Firefox (Private Browsing)". Below that in tan background the usual File, Edit, View etc. Below that a tab with: the fox image and "Mozilla Firefox Start Page" Below thaat: back arrow, forward arrow, the "Go to a website" box, and on the right side a blue g, and a dropdown tab for search engines, down arrow for downloads, and the house symbol. bottom line is the usual Google line that shows my most used bookmarks The large area below that contains the Fox symbol in the center above the search box (which doesn't work). In the upper right is "mozilla" in grey type. Across the bottom is a light gray banner with "downloads, bookmarks, history, add-ons, sync and Settings" with their symbols above. I had to remove PC Matic Supershield to get the download to work at all, and now after hours of trials, I'm right back where I started.

Chosen solution

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.


Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Read this answer in context 1

Additional System Details

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1) AppleWebKit/537.17 (KHTML, like Gecko) Chrome/24.0.1312.57 Safari/537.17

More Information

A chart appeared, but the information isn't explained and I don't know how to use it.
I clicked "show details" below, and nothing happened.

the-edmeister
  • Top 10 Contributor
  • Moderator
3195 solutions 24387 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

Question owner

Since I can't open a proper Firefox page, there is no way to open Help. As I said, I can do nothing.

cor-el
  • Top 10 Contributor
  • Moderator
10739 solutions 96645 answers

Chosen Solution

Make sure that you do not run Firefox in (permanent) Private Browsing mode.

  • Tools > Options > Privacy > Firefox will: "Use custom settings for history"
  • Deselect: [ ] "Always use private browsing mode"

You can check for problems with preferences and try to rename or delete the prefs.js file and possible numbered prefs-##.js files and a possible user.js file to reset all prefs to the default values.


Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

A possible cause is security software (firewall,anti-virus) that blocks or restricts Firefox or the plugin-container process without informing you, possibly after detecting changes (update) to the Firefox program.

Remove all rules for Firefox and the plugin-container from the permissions list in the firewall and let your firewall ask again for permission to get full unrestricted access to internet for Firefox and the plugin-container process and the updater process.

See:

Question owner

Thanks for all the suggestions. Fortunately the first one, "deselect permanent Private Browsing" solved the problem.