X
Tap here to go to the mobile version of the site.
Your Firefox is out of date and may contain a security risk! Upgrade Firefox

Support Forum

how do I set google as my default search engine

Posted

Hello Firefox, Google comes up as my Home Page, but when I enter, it defaults to www.ask.com. How do I keep it on Google please? Thanks, Sharron

Additional System Details

Installed Plug-ins

  • Google Update
  • Next Generation Java Plug-in 10.11.2 for Mozilla browsers
  • Shockwave Flash 11.5 r502
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.5
  • GEPlugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 11.6.7.637
  • 4.1.10329.0
  • Citrix Offline Plug-in Mozilla Plug-in (Win32)
  • BlackBerry WebSL Browser Plug-In
  • Adobe Shockwave for Director Netscape plug-in, version 11.5.9.620
  • NPWLPG
  • Office Live Update v1.5
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • Office Authorization plug-in for NPAPI browsers
  • Logitech Harmony Remote Plugin
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; WOW64; rv:18.0) Gecko/20100101 Firefox/18.0

More Information

Tyler Downer
  • Administrator
  • Moderator
1164 solutions 6639 answers

The Reset Firefox feature can fix many issues by restoring Firefox to its factory default state while saving your essential information. Note: This will cause you to lose any Extensions, Open websites, and some Preferences.

To Reset Firefox do the following:

  1. Go to Firefox > Help > Troubleshooting Information.
  2. Click the "Reset Firefox" button.
  3. Firefox will close and reset. After Firefox is done, it will show a window with the information that is imported. Click Finish.
  4. Firefox will open with all factory defaults applied.


Further information can be found in the Reset Firefox – easily fix most problems article.

Did this fix your problems? Please report back to us!

cor-el
  • Top 10 Contributor
  • Moderator
10750 solutions 96740 answers

Try to reset some preferences to the default with the SearchReset extension:

Note that the SearchReset extension only runs once and then uninstalls automatically, so it won't show on the "Firefox > Add-ons" page (about:addons).

Check the browser.search.defaultenginename pref on the about:config page and make sure that it is set to the default value Google.

  • browser.search.defaultenginename
arttu 0 solutions 1 answers

Well I had a problem with Bing being the search engine used when entering search query into address bar. Changing default engine name did not help, and maybe that can be changed enough by just selecting other search engine in search bar.

But to the solution. I reseted keyword.URL preference in about:config, and now writing to the address bar uses Google to do the search.