X
Tap here to go to the mobile version of the site.

Support Forum

Why does hitting the ESC key no longer stop a page from loading?

Posted

When I was using the old version of Firefox (13.something, I think), hitting the "ESC" key instantly stopped any page loading. This doesn't work in my current version (16.something). I have to click the X on the far right of the address bar. This inability to quickly stop a page from loading is beginning to remind me of Internet Explorer.

When I was using the old version of Firefox (13.something, I think), hitting the "ESC" key instantly stopped any page loading. This doesn't work in my current version (16.something). I have to click the X on the far right of the address bar. This inability to quickly stop a page from loading is beginning to remind me of Internet Explorer.

Chosen solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Read this answer in context 1

Additional System Details

Installed Plug-ins

  • Garmin Communicator Plug-In 4.0.4.0
  • Shockwave Flash 11.3 r300
  • Adobe PDF Plug-In For Firefox and Netscape
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.0; rv:15.0) Gecko/20100101 Firefox/15.0.1

More Information

Tyler Downer
  • Top 25 Contributor
  • Moderator
1530 solutions 10669 answers

This works fine for me, try to update to Firefox 17.0.1, Update Firefox to the latest release then reset Firefox. Refresh Firefox - reset add-ons and settings

This works fine for me, try to update to Firefox 17.0.1, [[Update Firefox to the latest version]] then reset Firefox. [[Reset Firefox – easily fix most problems]]
cor-el
  • Top 10 Contributor
  • Moderator
17477 solutions 157949 answers

Chosen Solution

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do not click the Reset button on the Safe mode start window or otherwise make changes.
Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do not click the Reset button on the Safe mode start window or otherwise make changes. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes

Question owner

It seems to be working now, thanks!

It seems to be working now, thanks!