Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

downloaded last 2 versions neither registers as there-for example add on message says: This Persona requires Firefox 3.6. You are currently using Firefox 3.5.7.

  • 1 reply
  • 2 have this problem
  • 33 views
  • Last reply by James

more options

I downloaded version 17 today- -i checked it several times-and tried unpacking it 3 different times--thinking it shorted out somewhere and didn't tell me Facebook has been telling me for weeks that I have an older version of the browser that doesn't support FB and I should upgrade. Tried to add a persona and get this message This Persona requires Firefox 3.6. You are currently using Firefox 3.5.7..

Please help! I can't watch your videos because dial up is so basic. I am home with health problems so going out now to coffee shops, etc not possible. Thank you!

All Replies (1)

more options

Your useragent is Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.7) Gecko/20091221 Firefox/3.5.7 Glue/4.5 (.NET CLR 3.5.30729) FBSMTWB

See https://support.mozilla.org/en-US/kb/websites-say-firefox-outdated-or-incompatible

It is stuck at Firefox 3.5.7 due to the "Fast Browser Search" installed at time. Firefox 4.0 and newer UA's do not get affected.