Search Support

how to contact support when I can not download the latest version?

  • 1 reply
  • 7 have this problem
  • 267 views
  • Last reply by philipp

more options

I keep getting a message that soon my browser will no longer be supported so I try to get the new version of firefox and get the message "Your system doesn't meet the requirements to run Firefox. " I try to contact FF support and get the message I must have the latest version of FF to proceed... so Iam being sent in a vicious circle.... I have 2 powerpc running osx10.4.11 and 10.5.8 respectively... these do everything I need a laptop to do but now I am having this issue that I soon may not have a browser HELP

All Replies (1)

more options

hello, the last firefox that ran on macs with the powerpc architecture was version 3.6.28, which is now also outdated and affected by various security vulnerabilities.

Firefox no longer works with Mac OS X 10.4 or PowerPC processors

you could switch to tenfourfox - this is a browser based on mozilla that is maintained & kept up-to-date by an independent project (the downside is, it doesn't support plugins, like flash player): www.floodgap.com/software/tenfourfox/