Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firebug icon does not appear in Firefox 16, how to launch Firebug?

  • 10 replies
  • 4 have this problem
  • Last reply by Paul.Wormer

more options

I have Firebug 1.10.6 installed on top of Firefox 16.0.2. After installation of Firebug I see the bug icon in the upper right corner of my window, next to the home icon. After restarting Firefox, the icon is gone. I don't know how to start Firebug other than by clicking the icon. Please explain to me: how to get the Firebug icon after restarting Firefox, or, alternatively, how to start Firebug without icon.

Chosen solution

I did a reset (took a while) and added 3 extensions: spell check, LastPass, and Firebug. They all three seem to work now. This reset was a bit rigorous, but Firefox seems to be OK now. Thank you for your help.

Read this answer in context 👍 0

All Replies (10)

more options

hello paul, you should always be able to access firebug through the orange firefox button > web developer. or as an alternative you can customize the controls and add the firefox icon to the toolbar again...

more options

Thank you madperson. I tried both solutions already earlier. Under the button "web developer" I see a "debugger" button (ctrl-shift-s), but clicking it does not give Firebug. It gives another debugger.

Also under "Customize Toolbar" there is no Firebug item. There is a LastPass item (for a password manager that I use) and a number of standard items (separator, space, etc.), but no Firebug.

PS I reinstalled Firebug and then saw exactly what madperson described. Closing and starting Firefox removed Firebug: both in the web developers pop up and in the customize toolbar.

Modified by Paul.Wormer

more options

ok this is strange, can you check in firefox > addons > extensions if firebug is still installed/enabled?

more options

Yes in the list of extensions I see Firebug, but without the bug icon. After I have reinstalled Firebug I see the icon (which is gone after restarting Firefox).

more options

maybe the files in your profile folder that store the information about your extensions might have become corrupted. please try this: go to firefox > help > troubleshooting information > profile - show folder... then windows explorer should open up your profile folder. in there look for the files named extensions.ini, extensions.sqlite, extensions.sqlite-journal (and in some cases also extensions.txt, extensions.rdf). delete or rename those files and quit firefox, they will be regenerated the next time you launch firefox.

also see

more options

I did what you suggested (deleted 3 files, .txt and .rdf were not present). After restart the files were recreated, no Firebug icon though! The content of extensions.ini follows:






Extension0=C:\Program Files (x86)\Mozilla Firefox\extensions\{972ce4c6-7e08-4474-a285-3208198ce6fd}

BTW my Firefox extension list (Tools/Add-ons/Extensions) is now empty, although the extensions LastPass and spelling-check seem to work properly.

more options

hmm, in this case maybe do a total reset of the browser (your bookmarks & passwords will be kept - but you'd have to install the addons again afterwards): Refresh Firefox - reset add-ons and settings

more options

Chosen Solution

I did a reset (took a while) and added 3 extensions: spell check, LastPass, and Firebug. They all three seem to work now. This reset was a bit rigorous, but Firefox seems to be OK now. Thank you for your help.

more options

Did you ever try to delete the localstore.rdf file as that is the first to try if there are problems with the toolbar customization?

more options

To cor-el: no I did not, had never heard of the file. How was I supposed to know?

IMHO, FF documentation is as good as non-existent, or, in any case, very cumbersome to search through. This little Firebug problem is a good example of that.