Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

right click, open Link in New Tab stopped working

more options

Right clicking on a link in page and selecting either open link in new tab or window does NOT work. Nothing hapens. Just started the other day. Also cannot use Ctrl and right click. Works in Chrome. Right click and paste, etc work.

Right clicking on a link in page and selecting either open link in new tab or window does NOT work. Nothing hapens. Just started the other day. Also cannot use Ctrl and right click. Works in Chrome. Right click and paste, etc work.

All Replies (12)

more options

Hmmm, a standard diagnostic to bypass interference by extensions (and some custom settings) is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Diagnose Firefox issues using Troubleshoot Mode) using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode."

If the site works correctly, this points to one of your extensions or custom settings as the problem.

To disable plugins as well, you can try here:

orange Firefox button or classic Tools menu > Add-ons > Plugins category

Any change in Safe Mode?

more options

Perfect, it now works again. Not sure of exact trouble spot, but you provided excellent path to follow. Thanks. And in the process I also learned about the "pin as App Tab" ability which is great (and highly recommended)!

more options

I'm seeing the same problem on Ubuntu with Firefox 18.0.1. It just started after a recent update of Ubuntu which included a Firefox update. I'm guessing it was on Jan. 22 or maybe one or two days earlier.

more options

FF18, W7-64b:same problem. Right Click does not show anymore the menu with ´Open in new tab` etc. Right clicks are now the same as left clicks. Same site does work correctly with Chrome and IE. Tried FF 19 beta: samebproblem.

more options

Hi Michaelhdv, did you try the Safe Mode test described in my earlier post? This would be helpful in determining whether an add-on is causing this problem.

more options

Hi Jscher2000, thanks for replying. I tried safe mode. I tried resetting FF. I tried FF 19 beta. I tried de-installing and downloading a fresh copy of FF. The problem stays however. Funny thing is that I have this problem only with one website (, a Dutch newspaper). But Chrome and IE work as expected with this site so I am in doubt now. It must be ´something´within FF or ´something´ with the site which causes this behavior when one combines these two.

more options

Hi Michaelhdv, many sites have scripts that try to prevent copying by changing the behavior of the right-click menu. To see whether this is an issue, could you test the following setting and see whether it makes any difference:

orange Firefox button or classic Tools menu > Options > Content

To the right of "Enable JavaScript" click the Advanced button and uncheck the box for "Disable or replace context menus". (If the box is already unchecked, then never mind.) Then OK out of the dialog.

If you reload the site, does the right-click behavior change?

Of course, many sites make good use of the right-click. If you keep this setting, then Firefox's right-click menu will pop up in front of the site's menu, e.g., on Google Maps. To dismiss Firefox's menu so you can access the site's menu, a single tap on the Esc key usually works.

more options

Hi Jscher2000, No, I´m sorry the problem is still there. I will contact the site if they changed anything, just to be sure.

more options

Try a clean reinstall and delete the Firefox program folder before reinstalling a fresh copy of Firefox.

Download a fresh Firefox copy and save the file to the desktop.

Uninstall your current Firefox version, if possible, to cleanup the Windows registry and settings in security software.

  • Do NOT remove personal data when you uninstall your current Firefox version, because all profile folders will be removed and you will also lose your personal data like bookmarks and passwords from profiles of other Firefox versions.

Remove the Firefox program folder before installing that newly downloaded copy of the Firefox installer.

  • It is important to delete the Firefox program folder to remove all the files and make sure that there are no problems with files that were leftover after uninstalling.
  • (32 bit Windows) C:\Program Files\Mozilla Firefox\
  • (64 bit Windows) C:\Program Files (x86)\Mozilla Firefox\

Your bookmarks and other profile data are stored in the Firefox Profile Folder and won't be affected by an uninstall and (re)install, but make sure that "remove personal data" is NOT selected when you uninstall Firefox.

If you keep having problems then also create a new profile.

more options

Hi Cor-el, thanks for your help! I followed your instructions but the problem is still there. The sitemanager reported that they didn´t change anything recently. As FF behaves normal with all (!) other sites I still think that the problem is in one way or another related to this specific site ( The only thing I see is that their hyperlinks are ´.dhtml´ and not just ´.html´. However IE and Chrome work perfectly fine with this site. Strange...

more options

The .dhtml links work for me on the Volkskrant site, either with a normal left-click or with a middle-click to open the link in a new tab.

Try to boot the computer in Windows Safe mode with network support (press F8 on the boot screen) as a test to see if that helps.

more options

There was a server glitch and Michaelhdv's post about finding a workaround got lost. I think the workaround involved this extension:

From Notification email:

Michaelhdv wrote:

"Spent a day Google-ing with different words. Found this time an add-on for FF (RightToClick). It controls the behavior of JavaScript.  Installed it. Initially I just lost the mouse pointer but that is OK now.
Changed some of the parameters (see below) and right clicking is back! Nice thing is you may activate this add-on a specific webpage only which I did.
I unchecked (on top of the defaults):
disable page focus handlers
disable copy/paste/ etc handlers
disable page mouse move handlers.
Those three did the trick for me at least.
Thanks to all of you for your help!"

Modified by jscher2000 - Support Volunteer