Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 15 disabling Flash 11.2 but Linux won't get 11.3

  • 9 replies
  • 22 have this problem
  • Last reply by cor-el

more options

Adobe tells us that Flash 11.2 is the last version for Linux they'll provide. After upgrading to Firefox 15 it disables the latest Flash version (11.2) and tells me that it's too old and I've to update. Funny. :| What can I do? Is it possible to override this "security feature"? Will there be a "bugfix"?

All Replies (9)

more options

The block list often provides the ability to re-enable a blocked add-on. Was there an Enable button for Shockwave Flash and did it work?

It is possible to "hack" the block list file; I don't recall the details, but I believe there are other threads on that.

more options


it's a plug-in - not an add-on. So it doesn't appear in add-on list at all. :|

Modified by SinCarne

more options

Add-ons are divided into three different categories:


Can you find them all under Tools > Add-ons ? I'm not familiar with the Linux version of Firefox.

more options

Yes, you're right - sorry! It's there and active now but:

I've had downgraded to 14.0 which loaded and updated to 15.0 after restarting automatically. Now the problem does not exist anymore, the plugin ist still active. The first time I downloaded 15.0 and installed manually. Very, very strange at all. So I should mark it as solved?

more options

Sounds like you have solved it with Jscher2000 advice.

Just thought I would mention that I have several Firefox versions installed on Ubuntu and they are working ok with the FlashPlayer 11.2 plugins.

I am in Firefox 16 (Aurora - canonical) at the moment, I will start Firefox 14 (Release - mozilla) and upgrade it to see if I notice any problems with that. (I am not aware there are any blocks on Shockwave Flash/FlashPlayer )

more options


No problems when I upgraded from Fx14 to Fx15,and no mention of blocking. It is running the correct version of FlashPlayer

I checked using both /plugincheck and and both confirmed it was up to date.

You are apparently aware that Adobe has effectively stopped development of Linux versions of FlashPlayer (did it do similar with Android?). I think the agreement may be that some security fixes will be backported for 5 years where possible, and there was a minor version change recently

Users of Adobe Flash Player and earlier versions for Linux should update to Adobe Flash Player
more options

I have Flash working just fine on a variety of Firefox versions as it never gets disabled on any Firefox updates. Currently using it the current Nightly 18.0a1 from Mozilla even.

In my case I have the in ~/.mozilla/plugins/

more options

Hello everyone,

thanks for all of your quick replies! Indeed my problem is solved but I'm a little bit "unsatisfied" with the situation and afraid this might happen again with the next major update. I'd like to write down all the steps I've done. Maybe someone has an explanation for that behaviour.

My system is an Ubuntu 12.04 Linux, I'm not using the distro's version of Firefox but the stable one from the Mozilla website on release channel.

1. Yesterday I checked the About -> Info dialog to see if FF 15 is already ready. It told me that an update is available but it cannot upgrade and I've to visit the website and download. I did and extracted the FF 15 tarball into my firefox directory (/opt/firefox).

2. After restarting and auto-checking my add-ons by FF everything went fine. Later I saw that I cannot play anymore Youtube videos because of the missing flash player. I openend about:plugins and the flash plugin was missing indeed. I went to "plugincheck" and it told me in a bigger banner on the top (translated from German and not the original text):

-- Missing flash? Firefox has disabled Flash due to security reasons. Please update to the latest Flash version. --

3. After that I went to to Adobe's Flash website and downloaded the latest version ( I extracted each file to the destined directory. After several restarts of FF the plugin was still not active again.

4. I downgraded to FF 14 again. Everything was fine. I checked About -> Info again to see if I'm on 14 and that made him to auto-download FF 15 again - this time it was possible as an auto-update (compare to 1))

5. After the next restart of FF auto-update started and began to install FF 15 again. This time it did not disable the Flash plugin and everything was working.

-- About Flash 11.3: It was my suspicion that FF wanted to have a newer version than 11.2 because there is 11.3 for other platforms and I've had already installed the latest one for linux (see 3). This suspicion may be not true but I don't know. The Adobe website tells me the following (auto-translated from German):

-- NOTE: Adobe Flash Player 11.2 is the last version that still supports the Linux platform. Adobe continues to offer security to backport to Flash Player 11.2 for Linux. --

Can anyone tell me what happened wrong or in which step I possibly made a mistake? Thank you!!

more options

If there are problems with plugins not being detected properly then try to delete the pluginreg.dat file in the Firefox Profile Folder and if that didn't help also addons.sqlite.

Modified by cor-el