X
Tap here to go to the mobile version of the site.

Support Forum

FF8 doesn't remember App Tabs

Posted

I updated to Firefox 8.0 today and noticed my App Tabs aren't saved when I close Firefox.

I have set Firefox to open up my home page upon startup. Firefox 7 would open my home page along with any App Tabs from my previous session. Under Options>Privacy, I have set it to "Firefox will remember history". This problem also occurs when I have all my Add-ons disabled, so I am sure that's not what is getting in the way. Am I doing something wrong?

I updated to Firefox 8.0 today and noticed my App Tabs aren't saved when I close Firefox. I have set Firefox to open up my home page upon startup. Firefox 7 would open my home page along with any App Tabs from my previous session. Under Options>Privacy, I have set it to "Firefox will remember history". This problem also occurs when I have all my Add-ons disabled, so I am sure that's not what is getting in the way. Am I doing something wrong?

Additional System Details

Installed Plug-ins

  • Next Generation Java Plug-in 1.6.0_29 for Mozilla browsers
  • Shockwave Flash 11.0 r1
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape 10.1.1
  • 4.0.60831.0
  • IE Tab 2 Plug-in for Mozilla/Firefox
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • The plug-in allows you to open and edit files using Microsoft Office applications
  • np-mswmp

Application

  • User Agent: Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0

More Information

Application Basics
Name
Firefox
Version
8.0
User Agent
Mozilla/5.0 (Windows NT 6.1; rv:8.0) Gecko/20100101 Firefox/8.0
Profile Directory
Open Containing Folder
Enabled Plugins
about:plugins
Build Configuration
about:buildconfig
Crash Reports
about:crashes
Extensions
Name
Version
Enabled
ID
Add to Search Bar
2.0
true
add-to-searchbox@maltekraus.de
British English Dictionary
1.19.1
true
en-GB@dictionaries.addons.mozilla.org
ChatZilla
0.9.87
true
{59c81df5-4b7a-477b-912d-4e0fdf64e5f2}
DownThemAll!
2.0.8
true
{DDC359D1-844A-42a7-9AA1-88A850A938A8}
Flagfox
4.1.8
true
{1018e4d6-728f-4b20-ad56-37578a4de76b}
Google Docs Viewer
1.8
true
adonis.cuhk@gmail.com
IE Tab 2 (FF 3.6+)
3.10.7.2
true
{1BC9BA34-1EED-42ca-A505-6D2F1A935BBB}
NoScript
2.1.8
true
{73a6fe31-595d-460b-a920-fcc0f8843232}
RSS Ticker
9
true
{1f91cde0-c040-11da-a94d-0800200c9a66}
United States English Spellchecker
5.0.1
true
en-US@dictionaries.addons.mozilla.org
Woordenboek Nederlands
3.0.1
true
nl-NL@dictionaries.addons.mozilla.org
YouTube to MP3
1.2.3
true
youtube2mp3@mondayx.de
Java Console
6.0.29
false
{CAFEEFAC-0016-0000-0029-ABCDEFFEDCBA}
Mozilla Labs: Prospector - LessChrome HD
7
false
lessChrome.HD@prospector.labs.mozilla
Norton IPS
3.0
false
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.smartBookmarksVersion
2
browser.startup.homepage
https://mail.google.com/mail/?shva=1#inbox
browser.startup.homepage_override.buildID
20111104165243
browser.startup.homepage_override.mstone
rv:8.0
browser.tabs.warnOnClose
false
dom.ipc.plugins.enabled.npietab2.dll
true
extensions.lastAppVersion
8.0
keyword.URL
http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&btnI=745&q=
network.cookie.prefsMigrated
true
places.database.lastMaintenance
1320832554
places.history.expiration.transient_current_max_pages
96612
plugin.disable_full_page_plugin_for_types
privacy.cpd.cache
false
privacy.cpd.cookies
false
privacy.cpd.downloads
false
privacy.cpd.history
false
privacy.cpd.sessions
false
privacy.donottrackheader.enabled
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.OCSP.disable_button.managecrl
false
security.disable_button.openCertManager
false
security.disable_button.openDeviceManager
false
security.warn_viewing_mixed
false
Graphics
Adapter Description
ATI Radeon HD 5450
Vendor ID
1002
Device ID
68f9
Adapter RAM
1024
Adapter Drivers
aticfx32 aticfx32 aticfx32 atiumdag atidxx32 atiumdva
Driver Version
8.810.0.0
Driver Date
12-8-2010
Adapter RAM (GPU #2)
Unknown
Adapter Drivers (GPU #2)
Unknown
Direct2D Enabled
true
DirectWrite Enabled
true (6.1.7601.17563)
ClearType Parameters
ClearType parameters not found
WebGL Renderer
Google Inc. -- ANGLE -- OpenGL ES 2.0 (ANGLE 0.0.0.686)
GPU Accelerated Windows
1/1 Direct3D 10

cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158006 answers

Make sure that you do not use Clear Recent History to clear the Browsing History when you close Firefox.

Make sure that you do not use Clear Recent History to clear the <i>Browsing History</i> when you close Firefox. *https://support.mozilla.com/kb/Clear+Recent+History

Question owner

That is the setting at Options>Privacy, right? I have set it to remember history always.

That ''is'' the setting at Options>Privacy, right? I have set it to remember history always.
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158006 answers

Anything checked here?

  • Tools > Options > Privacy : History: [X] Clear history when Firefox closes > Settings
Anything checked here? *Tools > Options > Privacy : History: [X] Clear history when Firefox closes > Settings

Question owner

The first few options were indeed checked. I unchecked them, but it didn't change anything in Firefox's behaviour. I never have the "[ ] Clear history when Firefox closes" box checked in the first place, though.

After using Firefox for another day, I have noticed that, strangely, my App Tabs are remembered when the active tab isn't an App Tab at the moment I close Firefox. But if my active tab is an App Tab, they are all forgotten as soon as I close down.

Thanks for the effort so far. I really appreciate it.

The first few options were indeed checked. I unchecked them, but it didn't change anything in Firefox's behaviour. I never have the "[ ] Clear history when Firefox closes" box checked in the first place, though. After using Firefox for another day, I have noticed that, strangely, my App Tabs are remembered when the active tab isn't an App Tab at the moment I close Firefox. But if my active tab is an App Tab, they are all forgotten as soon as I close down. Thanks for the effort so far. I really appreciate it.
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158006 answers

Use "Firefox/File > Exit" to close Firefox

Use "Firefox/File > Exit" to close Firefox

Question owner

I am absolutely stupefied that this solved the problem. But as long as it works, I'm happy. Thanks a lot for all the help.

I am absolutely stupefied that this solved the problem. But as long as it works, I'm happy. Thanks a lot for all the help.
montyt63 0 solutions 4 answers

This doesn't do anything different for me--all tabs are still lost on Firefox restart.

This doesn't do anything different for me--all tabs are still lost on Firefox restart.

Question owner

Same here, unfortunately. The one time it worked seems to have been a fluke.

Same here, unfortunately. The one time it worked seems to have been a fluke.
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158006 answers

Make sure that you do not use Clear Recent History to clear the Browsing History when you close Firefox.

If you use cleanup software like CCleaner then check the settings for the Firefox application.

Make sure that you do not use Clear Recent History to clear the <i>Browsing History</i> when you close Firefox. *https://support.mozilla.com/kb/Clear+Recent+History If you use cleanup software like CCleaner then check the settings for the Firefox application.

Question owner

Here's a quick overview of all applicable settings:

  • I do not use Clear Recent History,
  • Tools>Options>Privacy: History is set to "Firefox will remember history" (no custom settings apply)
  • I make sure CCleaner doesn't delete Firefox's session, browsing history or any other relevant files.

Using these settings, Firefox still forgets the App Tabs I had before I closed it and just opens my home page upon startup.

Here's a quick overview of all applicable settings: * I do not use ''Clear Recent History'', * Tools>Options>Privacy: History is set to "Firefox will remember history" (no custom settings apply) * I make sure CCleaner doesn't delete Firefox's session, browsing history or any other relevant files. Using these settings, Firefox still forgets the App Tabs I had before I closed it and just opens my home page upon startup.
montyt63 0 solutions 4 answers

Helpful Reply

Found something that does work to automatically restore your previous session each time you reopen Firefox. It was under the Help section on restoring a previous session.

Go to Tools/Options and in the drop down menu under Start-up where it says "When Firefox starts:", click down to: "Show my windows and tabs from last time", and it will always restore your previous session.

Found something that does work to automatically restore your previous session each time you reopen Firefox. It was under the Help section on restoring a previous session. Go to Tools/Options and in the drop down menu under Start-up where it says "When Firefox starts:", click down to: "Show my windows and tabs from last time", and it will always restore your previous session.

Modified by montyt63

Question owner

That works for me, too. But I'm fairly sure Firefox is meant to be able to start a clean session on which your App Tabs from last time are already open.

That works for me, too. But I'm fairly sure Firefox is meant to be able to start a clean session on which your App Tabs from last time are already open.
montyt63 0 solutions 4 answers

I agree with you, but until somebody tells me how to get it to do that, at least this keeps me from starting from scratch every time.

FYI, I've also tried exiting from Firefox different ways and it still appears to works no matter how you exit out...and if you open a second Firefox window, it just opens a single tab on your home page.

I agree with you, but until somebody tells me how to get it to do that, at least this keeps me from starting from scratch every time. FYI, I've also tried exiting from Firefox different ways and it still appears to works no matter how you exit out...and if you open a second Firefox window, it just opens a single tab on your home page.

Modified by montyt63

montyt63 0 solutions 4 answers

I figured out another solution: I'm going back to Firefox 3 until they quit updating it...or until I find another browser to use!

I figured out another solution: I'm going back to Firefox 3 until they quit updating it...or until I find another browser to use!
cor-el
  • Top 10 Contributor
  • Moderator
17482 solutions 158006 answers

Helpful Reply

*App Tab Initializer: https://addons.mozilla.org/firefox/addon/app-tab-initializer/
intrue2 0 solutions 2 answers

App Tab Initializer: https://addons.mozilla.org/firefox/addon/app-tab-initializer/ seems to work.

Thanks cor-el.

App Tab Initializer: https://addons.mozilla.org/firefox/addon/app-tab-initializer/ seems to work. Thanks cor-el.

Modified by intrue2

angelflower2000us 0 solutions 1 answers

I tried this and it did not work

I tried this and it did not work