X
Tap here to go to the mobile version of the site.

Support Forum

How do I get Firefox search results to change link colors after viewing?

Posted

All other browsers I've used for searches always change the color or hue of the visited link. I just downloaded the latest Firefox version, but it doesn't do that either.

All other browsers I've used for searches always change the color or hue of the visited link. I just downloaded the latest Firefox version, but it doesn't do that either.

Chosen solution

. follow the advice of cor-el: Make certain that Remember my browsing history is checked. It is under the 'custom' selection. .

Read this answer in context 0

Additional System Details

This happened

Every time Firefox opened

This started when...

With download of Firefox

Installed Plug-ins

  • McAfee Clinic Activator Plugin (1,0,0,5)
  • Adobe ESD Version Manager 2.0
  • 1.5.0708.0
  • Adobe Shockwave for Director Netscape plug-in, version 10.2
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • 12.0.1.633
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Adobe PDF Plug-In For Firefox and Netscape 8.3.0
  • Provides additional functionality on Facebook. See our web site for details.
  • Google Update
  • Unity Player 3.3.0f4
  • Shockwave Flash 10.3 r181
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • Next Generation Java Plug-in 1.6.0_24 for Mozilla browsers
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Npdsplay dll
  • DRM Store Netscape Plugin
  • DRM Netscape Network Object

Application

  • User Agent: Mozilla/5.0 (Windows NT 5.1; rv:5.0.1) Gecko/20100101 Firefox/5.0.1

More Information

finitarry 251 solutions 3421 answers

I forced Firefox to use purple as the visited link colour by adding code to my userContent.css file in the profile directory, subdirectory chrome.

a:visited {color:#990099 !important;}

You can change the number to change the colour.

I forced Firefox to use purple as the visited link colour by adding code to my userContent.css file in the profile directory, subdirectory chrome. a:visited {color:#990099 !important;} You can change the number to change the colour.
Hasan 469 solutions 5600 answers

Helpful Reply

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Tools Menu -> Options -> Content -> click Colors... button -> place Checkmark on Allow pages to choose their own colors, instead of my selections above -> click OK

If it doesn't work, try this:

-> go to Tools Menu -> Options -> Content -> click Colors... button -> change the Visited Links color to whatever color you want -> click OK

Check and tell if its working.

-> Tap '''ALT''' key or press '''F10''' to show the Menu Bar -> go to Tools Menu -> Options -> Content -> click '''Colors...''' button -> place Checkmark on '''Allow pages to choose their own colors, instead of my selections above''' -> click OK If it doesn't work, try this: -> go to Tools Menu -> Options -> Content -> click '''Colors...''' button -> change the '''Visited Links color''' to whatever color you want -> click OK Check and tell if its working.

Modified by Hasan

Question owner

mha007: I have purple checked to show on visited pages, but a box is checked that changes that. When I uncheck this box "Allow pages to choose their own colors, instead of my selections above", it changes the background colors of different websites, too, which I don't want. My Yahoo is set for blue background and different heading colors, for example, and the unchecked box causes it goes to a stark white background with blue headlines, etc. Is there any way around this?

Thanks.

mha007: I have purple checked to show on visited pages, but a box is checked that changes that. When I uncheck this box "Allow pages to choose their own colors, instead of my selections above", it changes the background colors of different websites, too, which I don't want. My Yahoo is set for blue background and different heading colors, for example, and the unchecked box causes it goes to a stark white background with blue headlines, etc. Is there any way around this? Thanks.

Question owner

finitarry: When you put that code in for purple visited pages, did you also have the box checked "Allow pages to choose their own colors, instead of my selections above" under the Colors tab?

finitarry: When you put that code in for purple visited pages, did you also have the box checked "Allow pages to choose their own colors, instead of my selections above" under the Colors tab?
Hasan 469 solutions 5600 answers

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Tools Menu -> Options -> Content -> click Colors... button -> change Visited Links color to whatever color you want -> place Checkmark on Allow pages to choose their own colors, instead of my selections above -> click OK

Use both options together, its working for me. Check and tell if its working.

-> Tap ALT key or press F10 to show the Menu Bar -> go to Tools Menu -> Options -> Content -> '''click Colors... button''' -> change '''Visited Links''' color to whatever color you want -> place Checkmark on '''Allow pages to choose their own colors, instead of my selections above''' -> click OK Use both options together, its working for me. Check and tell if its working.

Question owner

Colors...Visited Links...was already set to purple with box "Allow pages to choose....." checked as I mentioned in my earlier reply. But I changed the Visited Links to Light Blue and unchecked and rechecked the box to "Allow pages to choose....". It does not work. It's either or for some reason.

Colors...Visited Links...was already set to purple with box "Allow pages to choose....." checked as I mentioned in my earlier reply. But I changed the Visited Links to Light Blue and unchecked and rechecked the box to "Allow pages to choose....". It does not work. It's either or for some reason.
Hasan 469 solutions 5600 answers

-> Tap ALT key or press F10 to show the Menu Bar

-> go to Help Menu -> select Restart with Add-ons Disabled

Firefox will close then it will open up with just basic Firefox. Now do this:

-> Update ALL your Firefox Plug-ins https://www.mozilla.com/en-US/plugincheck/

-> go to View Menu -> Zoom -> click Reset -> Page Style -> select Basic Page Style

-> go to View Menu -> Toolbars -> unselect All Unwanted/Incompatible Toolbars

-> go to Tools Menu -> Clear Recent History -> Time range to clear: select "EVERYTHING" -> click Details (small arrow) button -> place Checkmarks on Cookies, Cache -> click Clear Now

-> go to Tools Menu -> Options -> Content -> place Checkmarks on:

1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript

-> go to Tools Menu -> Options -> Privacy -> History section -> Firefox will: select "Remember History"

-> go to Tools Menu -> Options -> Security -> place Checkmarks on:

1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites

-> go to Tools Menu -> Options -> Advanced -> Network -> Offline Storage (Cache): click Clear Now button

-> Click OK on Options window

-> click the Favicon on SearchBar -> click Manage Search Engines -> select all Unwanted Search Engines and click Remove -> click OK

-> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious/Incompatible Extensions (Add-ons)

-> go to Tools Menu -> Add-ons -> Appearance section -> REMOVE All Unwanted/Suspicious/Incompatible Themes (Persona)

-> Restart Firefox

You can enable your Known & Trustworthy Add-ons and Themes later. Check and tell if its working.

-> Tap '''ALT''' key or press '''F10''' to show the Menu Bar -> go to Help Menu -> select '''Restart with Add-ons Disabled''' Firefox will close then it will open up with just basic Firefox. Now do this: -> Update ALL your Firefox Plug-ins https://www.mozilla.com/en-US/plugincheck/ -> go to View Menu -> '''Zoom''' -> click '''Reset''' -> '''Page Style''' -> select '''Basic Page Style''' -> go to View Menu -> Toolbars -> unselect All Unwanted/Incompatible Toolbars -> go to Tools Menu -> Clear Recent History -> '''Time range to clear: select "EVERYTHING"''' -> click Details (small arrow) button -> place Checkmarks on '''Cookies, Cache''' -> click '''Clear Now''' -> go to Tools Menu -> Options -> Content -> place Checkmarks on: 1) Block Pop-up windows 2) Load images automatically 3) Enable JavaScript -> go to Tools Menu -> Options -> Privacy -> History section -> '''Firefox will: select "Remember History"''' -> go to Tools Menu -> Options -> Security -> place Checkmarks on: 1) Warn me when sites try to install add-ons 2) Block reported attack sites 3) Block reported web forgeries 4) Remember Passwords for sites -> go to Tools Menu -> Options -> Advanced -> Network -> Offline Storage (Cache): click '''Clear Now''' button -> Click OK on Options window -> click the Favicon on SearchBar -> click '''Manage Search Engines''' -> select all Unwanted Search Engines and click '''Remove''' -> click OK -> go to Tools Menu -> Add-ons -> Extensions section -> REMOVE All Unwanted/Suspicious/Incompatible Extensions (Add-ons) -> go to Tools Menu -> Add-ons -> Appearance section -> REMOVE All Unwanted/Suspicious/Incompatible Themes (Persona) -> Restart Firefox You can enable your Known & Trustworthy Add-ons and Themes later. Check and tell if its working.
finitarry 251 solutions 3421 answers

I do allow pages to use their own colours, but if there are some colours that I want to change, I can do that with userContent.css.

I do allow pages to use their own colours, but if there are some colours that I want to change, I can do that with userContent.css.
cor-el
  • Top 10 Contributor
  • Moderator
17534 solutions 158559 answers

Make sure that the History is enabled: Tools > Options > Privacy > History: Remember my browsing history

Make sure that you do not run Firefox in permanent Private Browsing mode.

You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"

  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"
Make sure that the History is enabled: Tools > Options > Privacy > History: Remember my browsing history Make sure that you do not run Firefox in permanent Private Browsing mode. *https://support.mozilla.com/kb/Private+Browsing You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History" *To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting <b>Firefox will: Use custom settings for history</b> * Deselect: [ ] "Permanent Private Browsing mode"

Question owner

I really appreciate everything that you all have done in an effort to try to help solve this problem.

I just downloaded this evil V 5 the other day, I have no Add-Ons, I have History checked to clear when browser closes, I never have used Private Browsing and I run CCleaner daily. There should be no problems with Cache or Cookies as they're removed daily. And I'm weary of the effort just to try to solve this problem. So weary, in fact, that I GIVE UP. I may just go back to Chrome and put up with Google collecting my private information even though that is unacceptable business practice in my opinion.

Thanks again. Shirley

I really appreciate everything that you all have done in an effort to try to help solve this problem. I just downloaded this evil V 5 the other day, I have no Add-Ons, I have History checked to clear when browser closes, I never have used Private Browsing and I run CCleaner daily. There should be no problems with Cache or Cookies as they're removed daily. And I'm weary of the effort just to try to solve this problem. So weary, in fact, that I GIVE UP. I may just go back to Chrome and put up with Google collecting my private information even though that is unacceptable business practice in my opinion. Thanks again. Shirley
Hasan 469 solutions 5600 answers

-> Close Firefox (ALT + F -> Exit)

Start Firefox in Safe Mode by Holding down SHIFT key while starting Firefox

As an alternative method, select "Windows Start Menu -> Run" or press Win + R key combination and enter one of the following in the Windows Run box:

For Firefox, one of these:

      firefox -safe-mode
      "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode 

-> Firefox Safe Mode window will appear -> select Reset All User Preferences to Firefox Defaults and click Make Changes and Restart

Check and tell if its working.

-> Close Firefox (ALT + F -> Exit) Start Firefox in Safe Mode by Holding down '''SHIFT''' key while starting Firefox As an alternative method, select "Windows Start Menu -> Run" or press '''Win + R''' key combination and enter one of the following in the Windows Run box: For Firefox, one of these: firefox -safe-mode "C:\Program Files\Mozilla Firefox\firefox.exe" -safe-mode -> Firefox Safe Mode window will appear -> select '''Reset All User Preferences to Firefox Defaults''' and click '''Make Changes and Restart''' Check and tell if its working.
whoo 1 solutions 40 answers

Chosen Solution

. follow the advice of cor-el: Make certain that Remember my browsing history is checked. It is under the 'custom' selection. .

. follow the advice of cor-el: Make certain that Remember my browsing history is checked. It is under the 'custom' selection. .
whoo 1 solutions 40 answers

. Before you completely give up try this: tools/options/privacy/Firefox will: select "use custom settings for history"/check the box labeled: Remember My Browsing History/ok/ok โชคดี . Bill

. Before you completely give up try this: tools/options/privacy/Firefox will: select "use custom settings for history"/check the box labeled: Remember My Browsing History/ok/ok โชคดี . Bill