Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 5.0 cannot disply fonts correctly

  • 9 replies
  • 34 have this problem
  • 172 views
  • Last reply by cor-el

more options

I upgrade my web browser to Firefox 5.o recently. After that http://www.lankadeepa.lk/ web site fonts not display correctly. But Firefox 4.0 .. and IE can read it correctly.

All Replies (9)

more options

I took a look at your link, it's a bit of a mess eh?!

I'm not sure what language it was but try checking your Character Encoding from the View Menu and change to what you need.

You may also need to check some other settings from > Tools > Options > Content > then 'Fonts & Colours' and 'Languages'.

Modified by keithy397

more options

What kind of file type are prf files?

I don't think that Firefox recognizes that format as a font file. Is that meant for IE?

The font works if I install it locally and add local(Wijeya) to the src.


@font-face {
  font-family: Wijeya;
  font-style:  normal;
  font-weight: 700;
  src: url(../02/WIJEYA1.prf),local(Wijeya);
}

@font-face {
 font-family: Wijeya;
 font-style:  normal;
 font-weight: normal;
 src: url(../02/WIJEYA0.prf),local(Wijeya);
}

Modified by cor-el

more options

Hi Keithy397,

The language is Singhala and it works perfectly in FireFox version 4. This happend after I upgrade it in to newer version 5.0. I try with other FireFox installed machine, but same error happaning. It perfectly works on IE 8.0.

Thanks

more options

It seems that @font-face with an url but without a fallback to the locally installed font no longer works in Firefox 5.
I don't know if this is intended behavior or a regression, but I do not see an easy fix right now.

more options

I did another test that I forgot yesterday and disabled downloadable fonts. That works for me, so you can give that a try.

You can set the pref gfx.downloadable_fonts.enabled to false on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.
You can use the Filter bar at to top of the about:config page to locate a pref more easily.

more options

Dear Cor-el, Thanks for your effort. But above solution wasn't success. Pls see my finding below and help me,

Firefox 5.0 display garbage letters. So I copy that garbage from web page and paste it in to MS Office document. It convert that garbage characters to correct font "Wijaya". So that means, Web page already have the correct font, but display it wrongly. (web page display font as a "Arial" instead of "Wijaya").

Try to help me. Thanks.

more options

You can set the pref gfx.downloadable_fonts.enabled to false on the about:config page.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website. If you see a warning then you can confirm that you want to access that page. You can use the Filter bar at to top of the about:config page to locate a pref more easily.

=============================

Above solution worked fine for me....for XP SP3. It solved lanka-enews prob also. Rivira still case!

Thanks

Modified by dilhanf

more options

cor-el

Can you see a work around for this site? www.rivira.lk

Mind you that they do have a 'special notice' for FFx ppl on the top right! I use 'IE tab 2' add-on to read this on FFx.

Modified by dilhanf

more options

No, unfortunately not.

That site uses the Isiwara font and that font seems only available as .eot file and that only works for IE and not for other browsers or on platforms other than Windows.