Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube videos are blank black screen only on my firefox browser.

  • 91 replies
  • 2911 have this problem
  • 342366 views
  • Last reply by amplifier12

more options

I can't play any youtube videos on my firefox. All my programs are update to date. Also youtube videos are working for my internet explorer but not on my firefox. I have the latest version 3.6.13

I'm on a PC 32 bit home basic vista.

Modified by helpthisgame

Chosen solution

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the add-ons is causing the problem (switch to the DEFAULT theme: Tools > Add-ons > Themes).

  • Don't make any changes on the Safe mode start window.

See:

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")
Read this answer in context 👍 18

All Replies (20)

more options

None of the other solutions worked for me. This one did.

more options

i had problems with flash and after reinstall my antivirus software its ok

more options

try to reinstall your antivirus software

more options

un-check or remove this: ||youtube.com^ from the adblock scripts

more options

I had this problem too. I just tried to see if an add-on was causing the problem. One of them was. I disabled it and now the problem is fixed. :)

Add-on that caused the problem: TweakTube 1.0.7

more options

Turning off hardware acceleration on flash didnt work Clearing cookies/etc didnt work BUT disabling ADBLOCK PLUS on the webpages affected DID work (right click on their icon in the toolbar and click Disable on this page). Thanks Adblock, used you for years but you're history if this isnt fixed soon.

more options

I saw a post saying to disable adblock. So I did and it worked, then I turned adblock back on and it was still working. So I guess you can try disabling adblock then enabling it.

more options

no need to disable adblock totally just click adblock icon in address bar (or wherever it is on yoour browser page and click block on youtubes page. damm glad i found this thread had been using chrome for watching youtube till i found this thread. Now back with firefox the only browser that i want to use.

more options

I had the same issue, Deleting just the youtube cookies from firefox worked for me, I can now see youtube videos again in Firefox!

more options

Same here.. Cannot play any video from Youtube directly, but works if the video comes from facebook regular or Safe mode = does not work... Private Browsing Works !! - But not very convenient !!! Other Browsers work fine as well. Delete cookies and recent history did not help. I even re-installed Flash player V10. No luck. Windows 7 64 bits. Firefox 8.0

more options

I had to click forbid youtube.com from no script to make it work.

more options

Sir... The easiest way to get rid of this is update your Adobe Flash Player. Please visit: http://get.adobe.com/flashplayer/ and download the latest version of Adobe Flash Player & install it! VOILA!! You're good to go!

more options

same problem here. click "view" on toolbar. click on "adblock plus, blockable items" in the dropdown menu. this will show what is being blocked on the website. in the case of youtube, click on whatever ends in ".swf" and add a filter to make an exception. after the filter is added refresh the page and the video should start up again. i use a macbook pro.

Modified by campyhawaii

more options

Disabling ADP fixed it for me. Many many thanks

more options

http://bitrim.org/post/14122023085/bitrim-alpha-2-preview

I don't get a completely black screen. I can see the white text and play button, but neither do anything when clicked.

It's the HTML5 player that's been embedded so is not a flash problem.

Safe mode with all addons disabled does nothing.

Videos on the YT site itself work fine.

more options

Ok... I had the exact same problem... I tried everything you guys suggested without success... then I remember I had blocked something from youtube with adblock. So I went into Adblock settings and removed any personal filter I created (there were only 2 links, both from youtube). After that youtube went back to normal, working correctly, without any adds!

I'm pretty sure it was Addblock, since as soon as I tried and deactivate it, youtube would start to work again... but with AAAAALLL the adds!!! So try this out! Worked fine with me!

more options

I had this same issue until I disabled some plugins that I didn't even know were on. Go to Tools> addons> select plugins tab on the left. I disabled Adobe Acrobat, Getplusplus for Adobe, Foxit Reader, Microsoft Windows Media Player, and all others EXCEPT: DivX VOD, Java, Quicktime and Shockwave plugins (about 2 or 3 of each are listed and enabled). I went to youtube and voila - videos work perfectly again - no more frustration. I didn't need to clear history nor cache. I don't use adblock or any adblocking software/addon. Hope this helps.

Modified by intrimazz

more options

why should i have to try all this stuff when there is absolutely no problem in IE8, how do i get an older version of firefox PLEASE

more options

You have turned on AdBlock. You can't turn ads off on YouTube or you will also turn off the videos. Just play with changing your AdBlock settings.

more options

Change your adblock settings... you can't turn off ads on YouTube or you will turn off the videos too.

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5