X
Tap here to go to the mobile version of the site.

Support Forum

Some websites have major scroll lag in FF, but there is none in IE. Help!

Posted

I just got my new laptop and installed FF, but some websites have scrolling issues.

I have already tried running in Safe Mode and the issue remains, so I assume the problem is not any of my add-ons. I have also updated my gc drivers and re-installed FF, but to no avail.

I do not have this issue when i use Internet Explorer.

I just got my new laptop and installed FF, but some websites have scrolling issues. I have already tried running in Safe Mode and the issue remains, so I assume the problem is not any of my add-ons. I have also updated my gc drivers and re-installed FF, but to no avail. I do not have this issue when i use Internet Explorer.

Additional System Details

Sites Affected

http://www.newgrounds.com

Installed Plug-ins

  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • Winamp Application Detector
  • Default Plug-in
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Shockwave Flash 10.1 r53
  • iTunes Detector Plug-in
  • 3.0.40624.0
  • NPWLPG
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

More Information

Application Basics
Name
Firefox
Version
3.6.8
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Gmail Notifier
0.6.4.1
true
{44d0a1b4-9c90-4f86-ac92-8680b5d6549e}
Norton IPS
2.0
false
{BBDA0591-3099-440a-AA10-41764D9DB4DB}
Norton Toolbar
4.0
false
{4C0766D3-67A7-45a3-85A2-752F77312F32}
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.history_expire_days.mirror
180
browser.history_expire_days_min
7
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage
http://www.newgrounds.com
browser.startup.homepage_override.mstone
rv:1.9.2.8
extensions.lastAppVersion
3.6.8
font.name.serif.x-western
Arial
network.cookie.prefsMigrated
true
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
2
security.warn_viewing_mixed
false

Morbus 135 solutions 2340 answers

Do you have smooth scrolling enabled? Go into Tools > Options > Advanced > General > Browsing and untick Use smooth scrolling.

Smooth scrolling is known to cause issues on some websites, and it's a bug with Firefox that will be fixed in Firefox 4 (the fix is already in the beta versions, so you can try it if you want).

If that's not it, please tell me.

Do you have smooth scrolling enabled? Go into ''Tools > Options > Advanced > General > Browsing'' and untick ''Use smooth scrolling''. Smooth scrolling is known to cause issues on some websites, and it's a bug with Firefox that will be fixed in Firefox 4 (the fix is already in the beta versions, so you can [http://www.mozilla.com/en-US/firefox/all-beta.html try it] if you want). If that's not it, please tell me.
cor-el
  • Top 10 Contributor
  • Moderator
17519 solutions 158412 answers

Do the websites that cause that problem have a fixed background image?
Some video display drivers do not work very well with Firefox in case of such a fixed background image.

Try this bookmarklet as a test:

javascript:void(document.body.style.backgroundAttachment='scroll');

You need to use a bookmarklet on the page that has a problem.

See also http://en.wikipedia.org/wiki/Bookmarklet

Do the websites that cause that problem have a fixed background image?<br /> Some video display drivers do not work very well with Firefox in case of such a fixed background image. Try this bookmarklet as a test: javascript:void(document.body.style.backgroundAttachment='scroll'); You need to use a bookmarklet on the page that has a problem.<br /> See also http://en.wikipedia.org/wiki/Bookmarklet

Question owner

It's not smooth scrolling. I've experimented with it on and off. I have also played with autoscrolling but that is not the problem either.

As far as the bookmarkelt goes, I'm not exactly sure what that is... I'm not very well educated with this stuff. I went to the main website I'm having issues with (www.newgrounds.com) and copy/pasted what you posted into the browser, and the problem remains.

It's not smooth scrolling. I've experimented with it on and off. I have also played with autoscrolling but that is not the problem either. As far as the bookmarkelt goes, I'm not exactly sure what that is... I'm not very well educated with this stuff. I went to the main website I'm having issues with (www.newgrounds.com) and copy/pasted what you posted into the browser, and the problem remains.

Modified by snayk

Morbus 135 solutions 2340 answers

Helpful Reply

It's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal?

Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in safe mode (don't forget to select Disable all add-ons when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See this article for information about troubleshooting extensions and themes and this one for plugins.

If you need support for one of your add-ons, you'll have to contact its author.

If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.

It's possible that you are having a problem with some Firefox add-on that is hindering your Firefox's normal behavior. Have you tried disabling all add-ons (just to check), to see if Firefox goes back to normal? Whenever you have a problem with Firefox, whatever it is, you should make sure it's not caused by one (or more than one) of your installed add-ons, be it an extension, a theme or a plugin. To do that easily and cleanly, run Firefox in [http://support.mozilla.com/en-US/kb/Safe+Mode safe mode] (don't forget to select ''Disable all add-ons'' when you start safe mode). If the problem disappears, you know it's from an add-on. Disable them all in normal mode, and enable them one at a time until you find the source of the problem. See [http://support.mozilla.com/en-US/kb/Troubleshooting+extensions+and+themes this article] for information about troubleshooting extensions and themes and [https://support.mozilla.com/en-US/kb/Troubleshooting+plugins this one] for plugins. If you need support for one of your add-ons, you'll have to contact its author. If the problem does not disappear when all add-ons are disabled, please tell me, so we can work from there. Please have no fear of following my instructions to the line, as all can be easily undone.
cor-el
  • Top 10 Contributor
  • Moderator
17519 solutions 158412 answers

There are background-images on that page, but they scroll normally and thus shouldn't cause a problem. I do see however two Flash object at the left and right that are positioned absolutely and thus stay in the same position when scrolling.

You can try to block those two Flash objects with the Flash Block extension.

There are background-images on that page, but they scroll normally and thus shouldn't cause a problem. I do see however two Flash object at the left and right that are positioned absolutely and thus stay in the same position when scrolling. You can try to block those two Flash objects with the Flash Block extension. * Flash Block: https://addons.mozilla.org/firefox/addon/433 * Adblock Plus: https://addons.mozilla.org/firefox/addon/1865

Question owner

As I mentioned in my original post, I have already tried running in Safe Mode and disabling all of the add-ons. I have also tried running FF normally with the add-ons disabled, but the scroll lag is still an issue.

I will try to block those Flash objects now and will post again after with results.

As I mentioned in my original post, I have already tried running in Safe Mode and disabling all of the add-ons. I have also tried running FF normally with the add-ons disabled, but the scroll lag is still an issue. I will try to block those Flash objects now and will post again after with results.

Question owner

I just tried using Flash Block and it successfully blocked the ads. However, I am still experiencing bad scroll lag.

I just tried using Flash Block and it successfully blocked the ads. However, I am still experiencing bad scroll lag.
Morbus 135 solutions 2340 answers

Yes, that was to be expected, if safe mode without add-ons had the same issue. Can you please try it in a new (temporary) Firefox profile and see if the issue is still present? See this article to know how to create a new Firefox profile. Please report back the results.

Yes, that was to be expected, if safe mode without add-ons had the same issue. Can you please try it in a new (temporary) Firefox profile and see if the issue is still present? See [http://support.mozilla.com/en-US/kb/Managing+profiles this article] to know how to create a new Firefox profile. Please report back the results.

Question owner

I made a new profile, and I DID experience much reduced lag (almost none). A few changes brought me back to my old issue again, so it did help to narrow down the problem...

In its original state, the page is almost lagless. However, upon loading it I immediately noticed that the font was smaller than I like. I held Ctrl + scrolled on my mouse to adjust the page to where I like and tried scrolling, and voila; The lag became much worse and more noticeable.

I hope that the only solution isn't to keep the page's size in it's original state, because I'm running on a high resolution, so the font is extremely small and hard to read.

I tested this again in Internet Explorer (and this time I changed the font size there as well), but there was still no lag, even in the page's enlarged state.

I made a new profile, and I DID experience much reduced lag (almost none). A few changes brought me back to my old issue again, so it did help to narrow down the problem... In its original state, the page is almost lagless. However, upon loading it I immediately noticed that the font was smaller than I like. I held Ctrl + scrolled on my mouse to adjust the page to where I like and tried scrolling, and voila; The lag became much worse and more noticeable. I hope that the only solution isn't to keep the page's size in it's original state, because I'm running on a high resolution, so the font is extremely small and hard to read. I tested this again in Internet Explorer (and this time I changed the font size there as well), but there was still no lag, even in the page's enlarged state.
Morbus 135 solutions 2340 answers

Helpful Reply

It may well be that the only solution (for now) is to keep the zoom level at default (press CTRL+0 - that's zero - to restore it or go into View > Zoom > Reset). I heard of other cases where zoom would make pages lag. This problem will be gone in Firefox 4, along with most (if not all) scroll problems. Firefox 4 beta is still not good enough for day to day use, but you can still try it if you want.

It may well be that the only solution (for now) is to keep the zoom level at default (press CTRL+0 - that's zero - to restore it or go into ''View > Zoom > Reset''). I heard of other cases where zoom would make pages lag. This problem will be gone in Firefox 4, along with most (if not all) scroll problems. Firefox 4 beta is still not good enough for day to day use, but you can still [http://www.mozilla.com/en-US/firefox/all-beta.html try it] if you want.

Question owner

Blegh, that's a drag. I'll probably try out FF 4 at some point to see if it helps anything. I'm just disappointed that I can't use this feature in FF without the lag.

Thanks a lot for the help, guys.

EDIT: Also, not sure if I should click on one of the posts to say it "solved" the problem, because (unfortunately) it seems that instead of a solution I am stuck with a work-around.

Blegh, that's a drag. I'll probably try out FF 4 at some point to see if it helps anything. I'm just disappointed that I can't use this feature in FF without the lag. Thanks a lot for the help, guys. EDIT: Also, not sure if I should click on one of the posts to say it "solved" the problem, because (unfortunately) it seems that instead of a solution I am stuck with a work-around.

Modified by snayk

Morbus 135 solutions 2340 answers

Well, there's no solution, really, at least not as far as I know. Don't mark it as solved though, maybe someone knows a better work around... I'm sorry I can't be of more help.

Well, there's no solution, really, at least not as far as I know. Don't mark it as solved though, maybe someone knows a better work around... I'm sorry I can't be of more help.
cor-el
  • Top 10 Contributor
  • Moderator
17519 solutions 158412 answers

You can try to increase the String pref layout.css.devPixelsPerPx from 1.0 to 2.0 in 0.1 steps to see what works best. In Firefox 3.6 and later this pref is a String value parsed to a float and allows to fine tune the dimensions of all elements more precisely.

To open the about:config page, type about:config in the location (address) bar and press the "Enter" key, just like you type the url of a website to open a website.
If you see a warning then you can confirm that you want to access that page.

You can try to increase the String pref layout.css.devPixelsPerPx from 1.0 to 2.0 in 0.1 steps to see what works best. In Firefox 3.6 and later this pref is a String value parsed to a float and allows to fine tune the dimensions of all elements more precisely. To open the <i>about:config</i> page, type <b>about:config</b> in the location (address) bar and press the "<i>Enter</i>" key, just like you type the url of a website to open a website.<br /> If you see a warning then you can confirm that you want to access that page.<br />

Question owner

Morbus: Don't worry about it, you were still very helpful. Thanks!

cor-el: Ok, I just tried playing with those settings, but unfortunately, it couldn't help the problem :(

Morbus: Don't worry about it, you were still very helpful. Thanks! cor-el: Ok, I just tried playing with those settings, but unfortunately, it couldn't help the problem :(
w1res 0 solutions 2 answers

Smooth-scroll does cause lag. Unfortunately it was not fixed in Firefox 4, and for me, it actually got much worse and I had to turn it off.

I think this is a nice feature to have, and it works in ie9 for me but not FF4.

Smooth-scroll does cause lag. Unfortunately it was not fixed in Firefox 4, and for me, it actually got much worse and I had to turn it off. I think this is a nice feature to have, and it works in ie9 for me but not FF4.
Morbus 135 solutions 2340 answers

Hum... It's working flawlessly on my end...

Hum... It's working flawlessly on my end...
cipher_nemo 0 solutions 1 answers

AdBlock add-on was causing my issue with this. The second I read Morbus' post about testing without add-ons, I kicked myself. I should have remembered that.

Either AdBlock has issues (I see the scroll problem happen on Facebook all the time), or I have a corrupt install of it. Either way removing it solved my issue. So I'm going to try to wipe it and then reinstall to troubleshoot.

AdBlock add-on was causing my issue with this. The second I read Morbus' post about testing without add-ons, I kicked myself. I should have remembered that. Either AdBlock has issues (I see the scroll problem happen on Facebook all the time), or I have a corrupt install of it. Either way removing it solved my issue. So I'm going to try to wipe it and then reinstall to troubleshoot.