X
Tap here to go to the mobile version of the site.

Support Forum

Cyrillic page titles display question marks instead of letters in Windows Title Bar

Posted

Firefox doesn't show cyrillic page titles in Windows Title Bar, instead of letters it shows question marks, like this "???????".

This happened

Every time Firefox opened

== recently

Firefox doesn't show cyrillic page titles in Windows Title Bar, instead of letters it shows question marks, like this "???????". == This happened == Every time Firefox opened == recently

Additional System Details

Installed Plug-ins

  • -2,4,9,1
  • ww-plugin
  • Version 1.1.2.0
  • Office Plugin for Netscape Navigator
  • np-mswmp
  • PLATINUM technology, inc. Plug-in for viewing 3D worlds authored in VRML
  • Adobe PDF Plug-In For Firefox and Netscape
  • Default Plug-in
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Google Update
  • Shockwave Flash 10.0 r45
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • Picasa plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • 3.0.50106.0
  • Office Live Update v1.5
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers
  • Java(TM) Platform SE binary
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers

Application

  • User Agent: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.2.3) Gecko/20100401 Firefox/3.6.3 ( .NET CLR 3.5.30729)

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Aging Tabs
0.7.1
true
aging-tabs@design-noir.de
Clipmarks
4.0.1
true
Drag & Drop.io
2.0.1
true
dropio@dropio
Flagfox
4.0.5
true
{1018e4d6-728f-4b20-ad56-37578a4de76b}
FoxyTunes
4.0.6
true
{463F6CA5-EE3C-4be1-B7E6-7FEE11953374}
Greasemonkey
0.8.20100408.6
true
Microsoft .NET Framework Assistant
1.2.1
true
{20a82645-c095-46ed-80e3-08825760534b}
SQLite Manager
0.5.15
true
SQLiteManager@mrinalkant.blogspot.com
SearchPreview
4.3
true
Skype extension for Firefox
3.3.0.3971
false
TVU Web Player
2,4,9,1
true
firefox@tvunetworks.com
TradeManager-Plugin
1.0
true
{4D144BC3-23FB-47de-90C5-63CCB0139CCF}
DownloadHelper
4.7.3
true
Java Console
6.0.20
true
Modified Preferences
Name
Value
accessibility.typeaheadfind.flashBar
0
browser.places.importBookmarksHTML
false
browser.places.importDefaults
false
browser.places.leftPaneFolderId
-1
browser.places.migratePostDataAnnotations
false
browser.places.smartBookmarksVersion
2
browser.places.updateRecentTagsUri
false
browser.startup.homepage
http://www.google.rs/
browser.startup.homepage_override.mstone
rv:1.9.2.3
dom.max_script_run_time
1800
extensions.lastAppVersion
3.6.3
font.language.group
x-cyrillic
font.name.sans-serif.x-cyrillic
Calibri
font.name.serif.x-cyrillic
Resavska BG
font.name.serif.x-western
Segoe UI
general.useragent.extra.microsoftdotnet
( .NET CLR 3.5.30729)
network.cookie.prefsMigrated
true
network.http.pipelining
true
network.http.pipelining.maxrequests
100
network.http.proxy.pipelining
true
places.last_vacuum
1273785855
print.print_printer
Send To OneNote 2007
print.printer_Send_To_OneNote_2007.print_bgcolor
false
print.printer_Send_To_OneNote_2007.print_bgimages
false
print.printer_Send_To_OneNote_2007.print_command
print.printer_Send_To_OneNote_2007.print_downloadfonts
false
print.printer_Send_To_OneNote_2007.print_edge_bottom
0
print.printer_Send_To_OneNote_2007.print_edge_left
0
print.printer_Send_To_OneNote_2007.print_edge_right
0
print.printer_Send_To_OneNote_2007.print_edge_top
0
print.printer_Send_To_OneNote_2007.print_evenpages
true
print.printer_Send_To_OneNote_2007.print_footercenter
print.printer_Send_To_OneNote_2007.print_footerleft
&PT
print.printer_Send_To_OneNote_2007.print_footerright
&D
print.printer_Send_To_OneNote_2007.print_headercenter
print.printer_Send_To_OneNote_2007.print_headerleft
&T
print.printer_Send_To_OneNote_2007.print_headerright
&U
print.printer_Send_To_OneNote_2007.print_in_color
true
print.printer_Send_To_OneNote_2007.print_margin_bottom
0.5
print.printer_Send_To_OneNote_2007.print_margin_left
0.5
print.printer_Send_To_OneNote_2007.print_margin_right
0.5
print.printer_Send_To_OneNote_2007.print_margin_top
0.5
print.printer_Send_To_OneNote_2007.print_oddpages
true
print.printer_Send_To_OneNote_2007.print_orientation
0
print.printer_Send_To_OneNote_2007.print_pagedelay
500
print.printer_Send_To_OneNote_2007.print_paper_data
9
print.printer_Send_To_OneNote_2007.print_paper_height
11,00
print.printer_Send_To_OneNote_2007.print_paper_size_type
0
print.printer_Send_To_OneNote_2007.print_paper_size_unit
1
print.printer_Send_To_OneNote_2007.print_paper_width
8,50
print.printer_Send_To_OneNote_2007.print_reversed
false
print.printer_Send_To_OneNote_2007.print_scaling
1,00
print.printer_Send_To_OneNote_2007.print_shrink_to_fit
true
print.printer_Send_To_OneNote_2007.print_to_file
false
print.printer_Send_To_OneNote_2007.print_unwriteable_margin_bottom
0
print.printer_Send_To_OneNote_2007.print_unwriteable_margin_left
0
print.printer_Send_To_OneNote_2007.print_unwriteable_margin_right
0
print.printer_Send_To_OneNote_2007.print_unwriteable_margin_top
0
privacy.sanitize.migrateFx3Prefs
true
security.warn_viewing_mixed
false

cor-el
  • Top 10 Contributor
  • Moderator
17465 solutions 157833 answers

That issue can be caused by a problem with the font that is used for the Windows Title bar.

You can check core fonts like Arial, Verdana, Tahoma, Times New Roman in "Control Panel > Fonts" and make sure that they are not missing or corrupted.

That issue can be caused by a problem with the font that is used for the Windows Title bar. You can check core fonts like Arial, Verdana, Tahoma, Times New Roman in "Control Panel > Fonts" and make sure that they are not missing or corrupted.

Question owner

I should have stated in the first message that I have already checked that, and other aplications show cyrillic characters correctly. Internet Explorer shows the same title correctly whereas Firefox shows question marks.

Besides, Firefox used to display titles correctly too, I noticed this only recently, in the last week or so. I don't know what might have changed. I certainly did not change any settings by myself, that would cause this to happen.

Thanks for the try though.

I should have stated in the first message that I have already checked that, and other aplications show cyrillic characters correctly. Internet Explorer shows the same title correctly whereas Firefox shows question marks. Besides, Firefox used to display titles correctly too, I noticed this only recently, in the last week or so. I don't know what might have changed. I certainly did not change any settings by myself, that would cause this to happen. Thanks for the try though.

Question owner

I checked again, and now it seems to display correctly the same titles that yesterday were question marks. I did restart my computer earlier today. It seems that it is some bug that happens randomly.

I checked again, and now it seems to display correctly the same titles that yesterday were question marks. I did restart my computer earlier today. It seems that it is some bug that happens randomly.

Question owner

I have a same problem and it did not disappear. It happens all the time.

I have a same problem and it did not disappear. It happens all the time.
cor-el
  • Top 10 Contributor
  • Moderator
17465 solutions 157833 answers

The RealPlayer Browser Record Plugin extension (Tools > Add-ons > Extensions) has been reported to cause a similar issue by switching the title bar to UTF-16 encoding. If you do not have installed East Asian support then you will see boxes or ??? in the title bar.

Do not confuse the extension with the RealPlayer plugin (Tools > Add-ons > Plugins) that plays media files. The extension adds some extra features like saving media files. You can disable/remove the RealPlayer Browser Record Plugin extension in the RealPlayer Preferences (RealPlayer: Tools > Preferences > Download & Recording)

See also Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems --- Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems and Troubleshoot issues with plugins like Flash or Java to fix common Firefox problems

If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the Safe mode start window. You have to close and restart Firefox after each change via "File > Exit" (on Mac: "Firefox > Quit")

The ''RealPlayer Browser Record Plugin'' extension (Tools > Add-ons > Extensions) has been reported to cause a similar issue by switching the title bar to UTF-16 encoding. If you do not have installed East Asian support then you will see boxes or ??? in the title bar. Do not confuse the extension with the RealPlayer plugin (Tools > Add-ons > Plugins) that plays media files. The extension adds some extra features like saving media files. You can disable/remove the ''RealPlayer Browser Record Plugin'' extension in the RealPlayer Preferences (RealPlayer: Tools > Preferences > Download & Recording) See also [[Troubleshooting extensions and themes]] --- Start Firefox in [[Safe Mode]] to check if one of your add-ons is causing your problem (switch to the DEFAULT theme: Tools > Add-ons > Themes). See [[Troubleshooting extensions and themes]] and [[Troubleshooting plugins]] If it does work in Safe-mode then disable all your extensions and then try to find which is causing it by enabling one at a time until the problem reappears. You can use "Disable all add-ons" on the ''Safe mode'' start window. You have to close and restart Firefox after each change via "File > Exit" (on Mac: "Firefox > Quit")

Question owner

I don't have Real Player installed at all, not even any kind of plug-in or extension.

The thing is, it happens randomly, at least to me. So when I, for example restart the system, Firefox displays titles regularily. But at some point, after putting the system to sleep, or restarting Firefox, it starts behaving as described in the topic.

Therefore, it's some kind of bug, because I haven't noticed it in previous versions of Firefox, and I don't see any errors in Windows Application Event Log, nor System Event Log for that matter.

So, besides the procedure suggested above being tedious, I don't see how it could help. Maybe there really is an extension or plug-in causing the messed up page titles, but what if I need that plugin/extension. Nad remember, it didn't happen before.

I guess that, since there isn't a way of reproducing the error (I'm not sure how, why or when it starts happening), I have to assume it's a bug in Firefox. Every other Windows' application works correctly.

I don't have Real Player installed at all, not even any kind of plug-in or extension. The thing is, it happens randomly, at least to me. So when I, for example restart the system, Firefox displays titles regularily. But at some point, after putting the system to sleep, or restarting Firefox, it starts behaving as described in the topic. Therefore, it's some kind of bug, because I haven't noticed it in previous versions of Firefox, and I don't see any errors in Windows Application Event Log, nor System Event Log for that matter. So, besides the procedure suggested above being tedious, I don't see how it could help. Maybe there really is an extension or plug-in causing the messed up page titles, but what if I need that plugin/extension. Nad remember, it didn't happen before. I guess that, since there isn't a way of reproducing the error (I'm not sure how, why or when it starts happening), I have to assume it's a bug in Firefox. Every other Windows' application works correctly.

Question owner

I also have the same problem for some cyrillics containing webpages but not all of them. In case it shows ???, I open that webpage with Windows Internet Explorer and in it webpage works fine!

I also have the same problem for some cyrillics containing webpages but not all of them. In case it shows ???, I open that webpage with Windows Internet Explorer and in it webpage works fine!
cor-el
  • Top 10 Contributor
  • Moderator
17465 solutions 157833 answers

Helpful Reply

If a server doesn't send an encoding then Firefox uses the default encoding as set in "Tools > Options > Content" (Western ISO-8859-1). A possibility in such cases is to switch to "View > Character Encoding > Auto-Detect > Universal" to see if that makes Firefox switch to the correct encoding.

Firefox doesn't use the encoding as specified in a meta tag in the document if the server sends an encoding. You can check that via Tools > Page Info > General In such cases you can try a few different encoding settings via "View > Character Encoding". Try some like "Western (ISO-8859-1)" or an other Western encoding (Windows-xxxx) or "Unicode (UTF-8)" or "Auto-Detect > Universal"

If a server doesn't send an encoding then Firefox uses the default encoding as set in "Tools > Options > Content" (Western ISO-8859-1). A possibility in such cases is to switch to "View > Character Encoding > Auto-Detect > Universal" to see if that makes Firefox switch to the correct encoding. Firefox doesn't use the encoding as specified in a meta tag in the document if the server sends an encoding. You can check that via Tools > Page Info > General In such cases you can try a few different encoding settings via "View > Character Encoding". Try some like "Western (ISO-8859-1)" or an other Western encoding (Windows-xxxx) or "Unicode (UTF-8)" or "Auto-Detect > Universal"

Question owner

cor-el, you seem to be forgetting the fact that the pages I'm referring to textused to display correctlytext until recently. By recently I mean, before the latest Firefox upgrade, for example. So they are not some new pages that I just happened to open, they are newspaper sites that I read regularily, and that worked correctly in the past. Now I assume that they did not change their encoding, and I know I did not change mine. Besides, sometimes they work and sometimes they dont. So it's gotta be a bug. I don't think they change their encoding on a daily basis, and neither do I. And the other browser displays the titles correctly. So it's just Firefox. Plain and simple.

cor-el, you seem to be forgetting the fact that the pages I'm referring to <u>text</u>used to display correctly<u>text</u> until recently. By recently I mean, before the latest Firefox upgrade, for example. So they are not some new pages that I just happened to open, they are newspaper sites that I read regularily, and that worked correctly in the past. Now I assume that they did not change their encoding, and I know I did not change mine. Besides, sometimes they work and sometimes they dont. So it's gotta be a bug. I don't think they change their encoding on a daily basis, and neither do I. And the other browser displays the titles correctly. So it's just Firefox. Plain and simple.

Question owner

Here I attach the title displayed correctly (just now), and I will attach the same snapshot next time it goes wrong.

Here I attach the title displayed correctly (just now), and I will attach the same snapshot next time it goes wrong.

Question owner

yeah mine is the same.

yeah mine is the same.

Question owner

Same here as Dragutin but the problem is always, It happens to me in every cirilic website that show the????? in the title bar only and the website content is ok showin cirilic as should.

I have W7 and FF 3.6.4 recently updated form 3.6.3 hoping it would solve the problem .

And as Dragutin only happens in FF not in Opera IE or Chrome

i tried all the suggested here, nothign works.

Same here as Dragutin but the problem is always, It happens to me in every cirilic website that show the????? in the title bar only and the website content is ok showin cirilic as should. I have W7 and FF 3.6.4 recently updated form 3.6.3 hoping it would solve the problem . And as Dragutin only happens in FF not in Opera IE or Chrome i tried all the suggested here, nothign works.

Question owner

Here's the screenshot when it screws up the page title.

Here's the screenshot when it screws up the page title.

Question owner

I noticed that the bug is window specific - opening the same page in a new window shows the new window title correctly. I attached the screenshot containing simultaneous correct and buggy display.

I noticed that the bug is window specific - opening the same page in a new window shows the new window title correctly. I attached the screenshot containing simultaneous correct and buggy display.

Question owner

Have same problem on W7 and FF3.6.3.

Have same problem on W7 and FF3.6.3.
mr_serge 0 solutions 1 answers

Have the same problem. Windows 7, Firefox 3.6.8 And it really shows a bug only when there are more than one tab open in one window. If I open the same page in new window, there is no problem.

P.S. Can't understand, where and how to see attachments you posted previous? I do not see any.

Have the same problem. Windows 7, Firefox 3.6.8 And it really shows a bug only when there are more than one tab open in one window. If I open the same page in new window, there is no problem. P.S. Can't understand, where and how to see attachments you posted previous? I do not see any.
mozillauser123 0 solutions 1 answers

I found this problem happens everytime computer resumes from hibernation. Also, when I open new Firefox window, characters show correctly in new window, but in first one there are question marks.

I found this problem happens everytime computer resumes from hibernation. Also, when I open new Firefox window, characters show correctly in new window, but in first one there are question marks.
cnapan 0 solutions 1 answers

I have the same problem here.

I'm running: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

- on windows 7

For example, the string 'Беларусь' (Belarus) appeared as ??????? in the page title. Like others above, if I open another firefox window, then this window displayed the title correctly. That title also contained non-cyrillic characters, and they rendered ok.

The same word ('Беларусь') appears correctly in the window itself, and if you view the source, then the <title> declaration looks correct too.

If I opened another firefox window, (without closing firefox), then that new window would display the title correctly.

The page I was using was this:

http://www.thefoundry.co.uk/partners/search/

- Select 'Belarus' from the option menu.


I just tried a test where I tried the page which had the ??????? in the title after exiting firefox, restarting, hibernating then unhibernating, but I couldn't get the problem to reappear.

I tend to use firefox heavily all day for work, and hibernate my machine each night. I'm not sure whether this bug is related to firefox having been used for a long time without a restart.

However, it is a real problem, and it isn't related to option settings or preferences being wrong - it seems specific to a window.

I have the same problem here. I'm running: Mozilla/5.0 (Windows; U; Windows NT 6.1; en-GB; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8 - on windows 7 For example, the string 'Беларусь' (Belarus) appeared as ??????? in the page title. Like others above, if I open another firefox window, then this window displayed the title correctly. That title also contained non-cyrillic characters, and they rendered ok. The same word ('Беларусь') appears correctly in the window itself, and if you view the source, then the <title> declaration looks correct too. If I opened another firefox window, (without closing firefox), then that new window would display the title correctly. The page I was using was this: http://www.thefoundry.co.uk/partners/search/ - Select 'Belarus' from the option menu. I just tried a test where I tried the page which had the ??????? in the title after exiting firefox, restarting, hibernating then unhibernating, but I couldn't get the problem to reappear. I tend to use firefox heavily all day for work, and hibernate my machine each night. I'm not sure whether this bug is related to firefox having been used for a long time without a restart. However, it is a real problem, and it isn't related to option settings or preferences being wrong - it seems specific to a window.
Rigel 0 solutions 1 answers

Exactly the same problem here: Window specific question marks appear on title bars and task bars after not having closed firefox for a long time, possibly in interrelation with using hibernate and/or sleep mode (though I wasn't able to reproduce the problem simply by entering these modes). That is to say, an old window won't display non-latin characters (cyrillic or chinese for instance) correctly but a new window opening the same page will display them correctly (even simultaneously as in a pic previously posted). Closing firefox while saving the current session keeps the problem intact, whereas closing firefox and opening thereafter a wholly new session removes the problem (for the time being) as if opening a new window in the current session. And I emphasize that the problem is only with title and task bars, the main content is shown correctly.

Tried everything already mentioned above, encoding is set to UTF-8 and auto-detect on Universal. Default encoding in Tools > Options > Content > Fonts & Colors > Advanced is on UTF-8. No Real-Player Plugins what so ever installed. Running on Vista, Fireforx 3.6.12.

Exactly the same problem here: Window specific question marks appear on title bars and task bars after not having closed firefox for a long time, possibly in interrelation with using hibernate and/or sleep mode (though I wasn't able to reproduce the problem simply by entering these modes). That is to say, an old window won't display non-latin characters (cyrillic or chinese for instance) correctly but a new window opening the same page will display them correctly (even simultaneously as in a pic previously posted). Closing firefox while saving the current session keeps the problem intact, whereas closing firefox and opening thereafter a wholly new session removes the problem (for the time being) as if opening a new window in the current session. And I emphasize that the problem is only with title and task bars, the main content is shown correctly. Tried everything already mentioned above, encoding is set to UTF-8 and auto-detect on Universal. Default encoding in Tools > Options > Content > Fonts & Colors > Advanced is on UTF-8. No Real-Player Plugins what so ever installed. Running on Vista, Fireforx 3.6.12.
.blah. 0 solutions 5 answers

Helpful Reply

I have the same problem too.

After I open a .pdf file titles in script different from Latin or Bulgarian turn to question marks. The reason why it works with Bulgarian script is because I have set Regional and Language Options > Advanced > Language for non-Unicode programmes to Bulgarian.

If I set it to Greek, then title pages in everything other than Latin and Bulgarian will be displayed as question marks after opening a .pdf file.

If I set it to Arabic, then it'll be all but Arabic and Latin... you get the drift.

I have the same problem too. After I open a .pdf file titles in script different from Latin or Bulgarian turn to question marks. The reason why it works with Bulgarian script is because I have set '''Regional and Language Options > Advanced > Language for non-Unicode programmes''' to Bulgarian. If I set it to Greek, then title pages in everything other than Latin and Bulgarian will be displayed as question marks after opening a .pdf file. If I set it to Arabic, then it'll be all but Arabic and Latin... you get the drift.

Modified by .blah.