X
Tap here to go to the mobile version of the site.

Support Forum

Firefox won't download addons due to error code 228

Posted

I am a new user to xubuntu 10.04, and I just installed it on a computer duel-booting with Vista. Whenever I try to download an add-on, the opens the download add-ons screen, but nothing else. Then, it quits out saying that Firefox could not install the file at https://addons.mozilla.org/en-US/firefox/downloads/latest/9825/addon-9825-latest.xpi?src=search because: Download error -228

This happened

Every time Firefox opened

== I tried to download an add-on

I am a new user to xubuntu 10.04, and I just installed it on a computer duel-booting with Vista. Whenever I try to download an add-on, the opens the download add-ons screen, but nothing else. Then, it quits out saying that Firefox could not install the file at https://addons.mozilla.org/en-US/firefox/downloads/latest/9825/addon-9825-latest.xpi?src=search because: Download error -228 == This happened == Every time Firefox opened == I tried to download an add-on

Additional System Details

Installed Plug-ins

  • -The Totem 2.30.0 plugin handles video and audio streams.
  • DivX Web Player version 1.4.0.233

Application

  • User Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.3) Gecko/20100423 Ubuntu/10.04 (lucid) Firefox/3.6.3

More Information

Application Basics
Name
Firefox
Version
3.6.3
Profile Directory
Open Containing Folder
Installed Plugins
about:plugins
Build Configuration
about:buildconfig
Extensions
Name
Version
Enabled
ID
Ubuntu Firefox Modifications
0.9rc2
true
ubufox@ubuntu.com
Modified Preferences
Name
Value
browser.places.importBookmarksHTML
false
browser.places.smartBookmarksVersion
2
browser.startup.homepage_override.mstone
rv:1.9.2.3
extensions.lastAppVersion
3.6.3
network.cookie.prefsMigrated
true
places.last_vacuum
1272833206
privacy.cpd.offlineApps
false
privacy.cpd.passwords
false
privacy.sanitize.migrateFx3Prefs
true
privacy.sanitize.timeSpan
0
security.warn_viewing_mixed
false

Question owner

ubuntu 10.04 64bits firefox 3.6.3

same problem too.

ubuntu 10.04 64bits firefox 3.6.3 same problem too.
cor-el
  • Top 10 Contributor
  • Moderator
17564 solutions 158858 answers
See http://kb.mozillazine.org/Unable_to_install_themes_or_extensions

Question owner

Ubuntu 10.04 64bits Firefox 3.6.3

Same problem...

Ubuntu 10.04 64bits Firefox 3.6.3 Same problem...

Question owner

The same.. An Ubuntu 10.04 just installed and Firefox 3.6.3. No modified, firefox not install all addons. With upgrade also rejects downloads of addons.

Screenshots

The same.. An Ubuntu 10.04 just installed and Firefox 3.6.3. No modified, firefox not install all addons. With upgrade also rejects downloads of addons. Screenshots

Question owner

Other screenshot. I hope it can be useful.

Other screenshot. I hope it can be useful.

Question owner

x64 Ubuntu 10.04

Firefox 3.6.3

x64 Ubuntu 10.04 Firefox 3.6.3

Question owner

See this link. http://kb.mozillazine.org/Unable_to_install_themes_or_extensio...

Turn off IPv6:

Enter in the URL address box:

about:config

Click "I'll be careful"

Type ipv6 in the filter box to get to the one and only line that's needed; it'll say network.dns.disableipv6

the default value is "false"; double-click to set the value to "true" (to disable IPv6)

See this link. [http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox] Turn off IPv6: Enter in the URL address box: about:config Click "I'll be careful" Type ipv6 in the filter box to get to the one and only line that's needed; it'll say network.dns.disableipv6 the default value is "false"; double-click to set the value to "true" (to disable IPv6)

Question owner

Sorry, Wrong link in the above entry

see: http://ubuntuforums.org/showthread.php?t=1476706&highlight=F...

Sorry, Wrong link in the above entry see: [http://ubuntuforums.org/showthread.php?t=1476706&highlight=Firefox+addons+download+error]

Question owner

It works! Thanks!

It works! Thanks!

Question owner

It works! Thanks! -->> James Firefox user

See this link. http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox

Turn off IPv6:

Enter in the URL address box:

about:config

Click "I'll be careful"

Type ipv6 in the filter box to get to the one and only line that's needed; it'll say network.dns.disableipv6

the default value is "false"; double-click to set the value to "true" (to disable IPv6)

It works! Thanks! -->> James Firefox user See this link. http://kb.mozillazine.org/Unable_to_install_themes_or_extensions_-_Firefox Turn off IPv6: Enter in the URL address box: about:config Click "I'll be careful" Type ipv6 in the filter box to get to the one and only line that's needed; it'll say network.dns.disableipv6 the default value is "false"; double-click to set the value to "true" (to disable IPv6)