Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube slow with firefox

  • 1 reply
  • 4 have this problem
  • 1 view
  • Last reply by jonzn4SUSE

more options

Bonjour, Hello,

I contact you because, even without an adblocker, Youtube is very slow with Firefox navigator. I don't understand why and I don't have this problem with Google Chrome ? Fews years earlier, I never had this problem with slow Youtube when using Firefox Navigator. I don't know if the problem comes from Youtube or Mozilla and I contacted both of them.

Thank you.

Bonjour,

Je vous contacte car, même sans bloqueur de publicité, Youtube est très lent avec le navigateur Firefox. Je ne comprends pas pourquoi et je n'ai pas ce problème avec Google Chrome ? Quelques années plus tôt, je n'avais jamais eu ce problème de lenteur avec Youtube lorsque j'utilisais Firefox Navigator. Je ne sais pas si le problème vient de Youtube ou de Mozilla et je les ai contactés tous les deux.

Bonjour, Hello, I contact you because, even without an adblocker, Youtube is very slow with Firefox navigator. I don't understand why and I don't have this problem with Google Chrome ? Fews years earlier, I never had this problem with slow Youtube when using Firefox Navigator. I don't know if the problem comes from Youtube or Mozilla and I contacted both of them. Thank you. Bonjour, Je vous contacte car, même sans bloqueur de publicité, Youtube est très lent avec le navigateur Firefox. Je ne comprends pas pourquoi et je n'ai pas ce problème avec Google Chrome ? Quelques années plus tôt, je n'avais jamais eu ce problème de lenteur avec Youtube lorsque j'utilisais Firefox Navigator. Je ne sais pas si le problème vient de Youtube ou de Mozilla et je les ai contactés tous les deux.

All Replies (1)

more options

Site works fine for me from New Jersey. see screenshot Who are you using for DNS?

Did you try with Firefox in Troubleshoot Mode? https://support.mozilla.org/en-US/kb/diagnose-firefox-issues-using-troubleshoot-mode

Did you clear the browser cache? https://support.mozilla.org/en-US/kb/how-clear-firefox-cache

Try Refresh Firefox. https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings

Modified by jonzn4SUSE

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.