Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

HTTP to HTTPS redirect causing issues with webpages is not loading and other certificate shenanigans.

  • No replies
  • 0 have this problem
more options

I have to configure a lot of networking equipment! One day I might be working on a brand new piece of equipment and the next day trying to log into some ancient piece of equipment because I need to change something and I can't replace it yet. I'm having a major issue with the redirect even if I explicitly type HTTP it forces it to HTTPS ( and no I don't have HTTPS everywhere installed I've actually never used it ). I've noticed recently a few updates back now that if the connection cannot succeed it redirects to HTTP but it can hang up in a weird limbo where it thinks the site doesn't exist. There needs to be a toggle for local addresses explicitly typed "HTTP" to try that first. There also needs a toggle to ignore the security issues when accessing the device with a self assigned certificate as every single networking device has a self assigned a certificate and every time I need to change the setting on a router I have to agree even though I have a greed for the last 10 times when I've access the device or I just reset the device and the self signed certificate changed. And I don't know how you're gonna handle this on mobile but it almost makes using a mobile browser useless because I might as well just get the computer out even if all I have to do is change a password, SSID or just check a setting.

So local addresses need an option to lower the warning level for self signed certificates and to obey the typed protocol!

And there's some sort of bug with the Logic that detects a certificate or non-secure site that breaks when the connection drops. The only way I've been able to get around this is to go to the address bar and hit enter as a reload will not work and a reload skipping cash will not work to bring the site back up.

I've had devices that I thought weren't working only to find out they were working fine after 3 or 4 attempts and restarts only to find it's just that firefox thought the site didn't exist anymore.

And I don't have any other options because chrome is even worse with HTTPS once it gets it's vampire fangs in you're stuck it will not let you go back. And safari you might as will be undead.

Finally getting annoyed enough to write some thing as every time you go change your setting reboot device check setting log back in change saying restart log back in and you have to hit except certificate every single time.

And while I'm here Bring back the checkbox to save/ not save the certificate as I might not want to save the certificate when I know I'm going to reset the device and it's going to be totally different in the next 10 minutes. Or I might not want to save it at all like I go to a website that's misconfigured and the certificates not valid for the domain name that it's using.

I have to configure a lot of networking equipment! One day I might be working on a brand new piece of equipment and the next day trying to log into some ancient piece of equipment because I need to change something and I can't replace it yet. I'm having a major issue with the redirect even if I explicitly type HTTP it forces it to HTTPS ( and no I don't have HTTPS everywhere installed I've actually never used it ). I've noticed recently a few updates back now that if the connection cannot succeed it redirects to HTTP but it can hang up in a weird limbo where it thinks the site doesn't exist. There needs to be a toggle for local addresses explicitly typed "HTTP" to try that first. There also needs a toggle to ignore the security issues when accessing the device with a self assigned certificate as every single networking device has a self assigned a certificate and every time I need to change the setting on a router I have to agree even though I have a greed for the last 10 times when I've access the device or I just reset the device and the self signed certificate changed. And I don't know how you're gonna handle this on mobile but it almost makes using a mobile browser useless because I might as well just get the computer out even if all I have to do is change a password, SSID or just check a setting. So local addresses need an option to lower the warning level for self signed certificates and to obey the typed protocol! And there's some sort of bug with the Logic that detects a certificate or non-secure site that breaks when the connection drops. The only way I've been able to get around this is to go to the address bar and hit enter as a reload will not work and a reload skipping cash will not work to bring the site back up. I've had devices that I thought weren't working only to find out they were working fine after 3 or 4 attempts and restarts only to find it's just that firefox thought the site didn't exist anymore. And I don't have any other options because chrome is even worse with HTTPS once it gets it's vampire fangs in you're stuck it will not let you go back. And safari you might as will be undead. Finally getting annoyed enough to write some thing as every time you go change your setting reboot device check setting log back in change saying restart log back in and you have to hit except certificate every single time. And while I'm here Bring back the checkbox to save/ not save the certificate as I might not want to save the certificate when I know I'm going to reset the device and it's going to be totally different in the next 10 minutes. Or I might not want to save it at all like I go to a website that's misconfigured and the certificates not valid for the domain name that it's using.

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.