Join the AMA (Ask Me Anything) with Firefox leadership team to talk about Firefox priorities in 2024. Mark your calendar! Thursday, June 13, 17:00 - 19:00 UTC.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Youtube Playback choppy / low frame rate in DEFAULT view only

more options

Device: Surface Pro X SQ2 OS: Windows 11 Home for ARM (Up-to-date at time of writing) Firefox Version: 125.0.3 (AArch64 up-to-date at time of writing)

I am having an issue with Firefox and video playback, specifically on YouTube. When I play a video in default view mode, the playback is super choppy / low frame rate. When I change to theatre view or full screen, playback works perfectly.

I've tried incognito windows and troubleshooting mode with no improvement.

Microsoft Edge works fine.

Not sure where to go from here.

Device: Surface Pro X SQ2 OS: Windows 11 Home for ARM (Up-to-date at time of writing) Firefox Version: 125.0.3 (AArch64 up-to-date at time of writing) I am having an issue with Firefox and video playback, specifically on YouTube. When I play a video in default view mode, the playback is super choppy / low frame rate. When I change to theatre view or full screen, playback works perfectly. I've tried incognito windows and troubleshooting mode with no improvement. Microsoft Edge works fine. Not sure where to go from here.

Chosen solution

Try disabling youtube's Ambient Mode.

Read this answer in context 👍 1

All Replies (3)

more options

Also, I've tried with and without hardware acceleration to no effect

Helpful?

more options

Chosen Solution

Try disabling youtube's Ambient Mode.

Helpful?

more options

That was it! Thank you!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.