Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

All Google websites are being blocked

  • 7 replies
  • 5 have this problem
  • Last reply by markd3

more options

All Google websites are being blocked after downloading 112.0.1

All Google websites are being blocked after downloading 112.0.1

All Replies (7)

more options

Are you using a proxy or VPN?

You can check the connection settings.

  • Settings -> General -> Network: Connection -> Settings

If you do not need to use a proxy to connect to internet, select "No Proxy" if "Use the system proxy settings" or one of the others do not work properly.

See "Firefox connection settings":

You can do a malware scan just to be sure.

more options

Do you get a specific error message when you try to visit Google sites, or just a blank page, etc.? More details would be helpful.

If you are having a secure connection problem, it sometimes is caused by a proxy server that Firefox discovered in your system settings. You can bypass that possible issue using the Preferences page. In the very tiny search box at the top of the page, type proxy and Firefox should filter to the "Network Settings" section.

Click the Settings button, select "No Proxy" near the top of the dialog, and click OK near the bottom of the dialog.

Any difference?

more options

The No Proxy is selected. Everything was fine until I download the latest FireFox. The error messages follows as: "Did Not Connect: Potential Security Issue

Firefox detected a potential security threat and did not continue to because this website requires a secure connection.

What can you do about it? has a security policy called HTTP Strict Transport Security (HSTS), which means that Firefox can only connect to it securely. You can’t add an exception to visit this site.

The issue is most likely with the website, and there is nothing you can do to resolve it. You can notify the website’s administrator about the problem."

It does this with almost everything Google. I have recheck some of the blocked sites and some are working again. Youtube is just the lastest of the new blocks.

Thanks for your reply!

more options

Usually that style of error page will have an "Advanced" button which you can click for more information, such as a technical error code that often starts with SEC_ERROR. Do you notice any pattern to the codes? This article has more information on them, in case it helps: How to troubleshoot security error codes on secure websites.

more options

I've also tried the YouTube blocked page in Safari and Chrome and the same thing happened, so it may not be FireFox. The only pattern I've noticed are Google websites. I check further on any patterns in the codes. Did you try the to see what happens?

more options

For me, redirects to and that displays:

404. That’s an error. The requested URL / was not found on this server. That’s all we know.

The server actually does send a 404 (page not found) error code, so if you are getting a weird result in all your browsers, it could be that an add-on or your ISP (DNS service provider) is intercepting/replacing 404's as an advertising opportunity. To try to work around an ISP doing it, you could turn on "DNS over HTTPS" in Firefox. This article has more information:

Firefox DNS-over-HTTPS

more options

Hi, same problem here:

"Blocked Page

An error occurred during a connection to "

I suspect it's "smartblock" feature mentioned in other posts about "Blocked Page" keyword. First time I see it. Was looking at a youtube video embedded in a site, in private-mode window, then clicked the top-left icon of yt-channel owner, which has among URL params "?embeds_euri=[embedding website]&...". FF opens it in new tab but instead it shows the above msg. Then any youtube / facebook / twitter URL from bookmarks fails to load in that tab, with same msg. (closing that tab and) opening URLs in new tabs works as usual, also the initial blocked channel after deleting the URL-params.

So perhaps it's smarkblock + security/privacy settings + some possible bug (would't expect locked tab)