Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

allowTabDetach not working

more options

If I set allowTabDetach to false it still allows it. If I just barely move a tab when clicking on it, it moves it to a new window. In other words, FF is ignoring the setting.

If I set allowTabDetach to false it still allows it. If I just barely move a tab when clicking on it, it moves it to a new window. In other words, FF is ignoring the setting.

All Replies (4)

more options

Hi, do you mean in about:config, you switched browser.tabs.allowTabDetach from true to false? That has always worked for me.

If you see a separate preference in about:config that is just allowTabDetach, that is not an official preference name and you can remove it using the trash can at the end of the row for that one.

Helpful?

more options

I was referring to the former.

Helpful?

more options

Nevermind. That setting only applies to the native tab bar. I use Tree Style Tabs. There's an addon setting I had to change. We'll see if it sticks.

Helpful?

more options

douglasquaid said

Nevermind. That setting only applies to the native tab bar. I use Tree Style Tabs. There's an addon setting I had to change. We'll see if it sticks.

Aha, that explains it. Add-on sidebar behaviors are determined by the add-on.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.