Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox will NOT Sream Fox Weather

  • 4 replies
  • 0 have this problem
  • 14 views
  • Last reply by cor-el

more options

Firefox will not Stream Fox weather It stays blank and black.

Firefox will not Stream Fox weather It stays blank and black.

All Replies (4)

more options

URL? And screenshot of your issue so others can view and compare if they have the same issue or not.

Helpful?

more options

You can check for issues with Total Cookie Protection.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

more options

Dropa said

URL? And screenshot of your issue so others can view and compare if they have the same issue or not.

I'm guessing https://www.foxweather.com/

Though I am geoblocked from viewing.

Helpful?

more options

You probably need to disable ETP (i.e. click the shield and move the slider to the 'off' position) and also make sure you do not block autoplay (click the autoplay button on the location bar). If you use content blocking extensions then make sure they do not block essential content (i.e. disable them).

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.