Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Home page after recent update (08/2022)

more options

After the recent update, the FF Homepage showqs 1 gigantic item per row.... It is ridiculous. Ive searched in efforts to find an option to rearrange this or go back to the previous format, unsuccessfully. Advise, please?

After the recent update, the FF Homepage showqs 1 gigantic item per row.... It is ridiculous. Ive searched in efforts to find an option to rearrange this or go back to the previous format, unsuccessfully. Advise, please?

All Replies (2)

more options

Firefox 103 now applies the Windows "Make text bigger" setting as a zoom multiplier (Release Notes).

Your options:

(A) If you do not need "Make text bigger" for other applications, the simplest thing you can do is reset that to 100% to resolve the issue:


(B) Firefox 103 has 3 interrelated hidden settings that control the overall zoom level and whether it considers information from the system.

First-Level Tweak

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste os-zoom and pause while the list is filtered

(3) Double-click the browser.display.os-zoom-behavior preference to display an editing field, and change the value to 0 then press Enter or click the blue check mark button to save the change.

For reference, these are the accepted values:

  • 0 => Ignore the OS-level scaling
  • 1 => Apply OS-level scaling as proportional zoom [default in Firefox 103]
  • 2 => Apply OS-level scaling as text-only zoom

Second-Level Tweak

If the above doesn't resolve the issue, this is the one to try next:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste ui.textScaleFactor and pause while the list is filtered.

Normally, Firefox will display a bar with Boolean Number String and a plus button. If Firefox displays a row that already has a number value, skip to step 5.

(3) Click the circular button in front of Number and then click the + button to create a new preference. (See composite screenshot below.)

(4) Firefox should display an editing field, and show a value of 0 -- edit the value to 100 then press Enter or click the blue check mark button to save the change.

(5) If the current value of ui.textScaleFactor is NOT 100, then double-click the preference to display an editing field, and change the value to 100 then press Enter or click the blue check mark button to save the change.

If 100 doesn't help, you could try 90 or 110 and see what value works best for you.

Helpful?

more options

If the user interface is okay and the problem is only on the built-in Firefox Home / new tab page, could you check the zoom level indicator in the address bar and if it's some ridiculous number, click it to go back to 100%.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.