Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox stops responding

  • 6 replies
  • 1 has this problem
  • 7 views
  • Last reply by Terry

more options

Since the last FF update I've been having issues with the browser locking up and not responding. Last time it did this I opened the windows task manager and found 11 FF exes running when I only had 1 tab open and all them were using excessive amounts of RAM. I shut down 7 of the before the browser closed on the 8th one. Why is this happening and how can I stop it?

Since the last FF update I've been having issues with the browser locking up and not responding. Last time it did this I opened the windows task manager and found 11 FF exes running when I only had 1 tab open and all them were using excessive amounts of RAM. I shut down 7 of the before the browser closed on the 8th one. Why is this happening and how can I stop it?

All Replies (6)

more options

You can look at the Firefox pages about:memory, about:processes and about:performance. The last is the Task Manager. I see a fair number of posts about RAM and I have had issues since last October. This article may help.

https://support.mozilla.org/en-US/kb/firefox-uses-too-much-memory-or-cpu-resources

Helpful?

more options

Unfortunately your answer does not address my issue of multiple FF exes running in the task manager consuming resources when only 1 FF window is open.

Helpful?

more options

Hello , When the latest version of FireFox opens a website with too many images, memory overflow may occur, which is a bug in the new version. Please try to use the old version or terminate the process of FireFox when it occupies too much RAM. Hope it can help you!

Helpful?

more options

Still doesn’t solve why there are so many FF exes running in the task manager. Thanks anyway.

Helpful?

more options

I've been having this issue on Window and Linux since 102 and just happened again today on 103. I've been running without my security software for about an hour and it has not had any issues for now. That's what I thought, but as I was typing this message it hung for about 30secs and it started to work again. I guess my security software is not the issue. Here's a screenshot from task manager at the time it stopped working. Running a total of 64 tabs in 2 windows.

Device name ZBook-17-G3 Processor Intel(R) Xeon(R) CPU E3-1535M v5 @ 2.90GHz 2.90 GHz Installed RAM 64.0 GB (63.9 GB usable) System type 64-bit operating system, x64-based processor Pen and touch No pen or touch input is available for this display Edition Windows 11 Pro Insider Preview Version 22H2 Installed on ‎20-‎Jul-‎22 OS build 25163.1010 Experience Windows Feature Experience Pack 1000.25163.1010.0

Modified by jonzn4SUSE

Helpful?

more options

The number of processes in your OS task manager is not unusual. You may be able to reduce the number by opting out of the fission experiment but that is unlikely to reduce your usage of RAM. Change the value of the following preference in about:config. fission.autostart You will have to restart the browser.

https://support.mozilla.org/en-US/kb/about-config-editor-firefox

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.