On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox is opening file in browser (displaying as text) instead of downloading/asking me what to do with the file

more options

I have a problem with how firefox is treating link to the file of type ".wotmod". For some reason firefox without asking is just opening file in the active tab (displaying it in the browser) when what I want to do is to download the file. Can i somehow force firefox to let me decide what to do with files of that extension? I did set action for all available ContentTypes to "Always ask" and I did check "Ask whether to open or save files" option in settings, but still Firefox is just opening those files in the browser. Other browsers like Chrome or Edge are letting me download the file, but I would prefer to use firefox for all my browsing needs. For anyone interested [[here|https://gitlab.com/wot-public-mods/replays-manager/-/releases]] is the link to gitlab release page containing multiple links to files of affected type. Below I have added screenshot of my settings: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-06-16-13-10-17-d4c7aa.png

I have a problem with how firefox is treating link to the file of type ".wotmod". For some reason firefox without asking is just opening file in the active tab (displaying it in the browser) when what I want to do is to download the file. Can i somehow force firefox to let me decide what to do with files of that extension? I did set action for all available ContentTypes to "Always ask" and I did check "Ask whether to open or save files" option in settings, but still Firefox is just opening those files in the browser. Other browsers like Chrome or Edge are letting me download the file, but I would prefer to use firefox for all my browsing needs. For anyone interested [[here|https://gitlab.com/wot-public-mods/replays-manager/-/releases]] is the link to gitlab release page containing multiple links to files of affected type. Below I have added screenshot of my settings: https://user-media-prod-cdn.itsre-sumo.mozilla.net/uploads/images/2022-06-16-13-10-17-d4c7aa.png
Attached screenshots

All Replies (9)

more options

This can possibly happen if the server is misconfigured and sends the file as text/plain instead of a valid content type registered in the OS for this file extension.

You can check this in the Network Monitor in the HTTP response headers of this request.

Helpful?

more options

cor-el said

This can possibly happen if the server is misconfigured and sends the file as text/plain instead of a valid content type registered in the OS for this file extension. You can check this in the Network Monitor in the HTTP response headers of this request.

You are right this file is send as "text/plain". Does this mean I can't use firefox to save those files unless someone changes how those files are being send? Isn't there some kind of way to force Firefox to allow me to save it?

Helpful?

more options

Can you right-click a link and select Save link as?

Helpful?

more options

Terry said

Can you right-click a link and select Save link as?

You are right, I can. But still in my book it is a workaround and not a solution.

Helpful?

more options

You can look at this extension.

Helpful?

more options

Unfortunately that didn't help.

Helpful?

more options

robertrocks2342 said

Mozilla Foundations plans to change how the Firefox browser handles downloads. The current stable version of Firefox displays a download prompt when the user attempts to download a file. The prompt lets you open the file in a specific app or save it to the default directory. Future Firefox updates will ditch this long-standing technique in favor of the idea found in Chrome, Edge, and other Chromium-based browsers.

Good to know. Is there any ETA of when this change should be available in Firefox or at least in developer/nightly build?

Helpful?

more options

It's old news (change is already implemented) and I don't think it would help you.

The only working solution is Content-Type Fixer, which has been suggested before. It must be configured, though.

Helpful?

more options

3mpy3ma said

cor-el said

You can look at this extension. Content-Type Fixer https://addons.mozilla.org/firefox/addon/content-type-fixer/

Unfortunately that didn't help.

My page here has the steps to set up a new file extension that isn't configured by default. Check the "Roll Your Own Content Type Overrides" section:

https://www.jeffersonscher.com/ext/content-type-fixer.html

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.