Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fonts not showing clearly

  • 2 replies
  • 1 has this problem
  • 5 views
  • Last reply by FredMcD

more options

Firefox was working fine after update to version 96.0. Firefox was no longer displaying Fonts correctly.

Interactive pages have become almost unusable. It is very difficult to navigate and fill in forms because most buttons and fields have no borders. The screen is mostly blank with just text and a few bits with borders. It is difficult to see where to click or add text.

I've tried resetting, running in safe mode and running with a fresh profile. None make any difference.

Some have Attached some screenshots

Firefox was working fine after update to version 96.0. Firefox was no longer displaying Fonts correctly. Interactive pages have become almost unusable. It is very difficult to navigate and fill in forms because most buttons and fields have no borders. The screen is mostly blank with just text and a few bits with borders. It is difficult to see where to click or add text. I've tried resetting, running in safe mode and running with a fresh profile. None make any difference. Some have Attached some screenshots
Attached screenshots

All Replies (2)

more options

[v56+] Type about:preferences#general<enter> in the address box. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Helpful?

more options

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.