Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

search bar and address bar issue

  • 6 replies
  • 1 has this problem
  • 44 views
  • Last reply by kamarkie1

more options

Hello, Can someone please tell me how to stop my "search bar" text from also showing up in my "address bar"? I have search the internet and found all of the following ways that have been suggested that have not worked.

I read that I should set the following to "false" to solve my problem.

1) keyword.enabled 2) browser.fixup.alternate.enabled 3) browser.urlbar.suggest.surches

I have also gone into the settings menu and un-checked everything I could find about suggestions or words or anything else being added to the address bar. The only thing that should show up in and address bar is................you guessed it: AN ADDRESS!  :-) Thanks so much for your help.

I really appreciate the help. Mark

Hello, Can someone please tell me how to stop my "search bar" text from also showing up in my "address bar"? I have search the internet and found all of the following ways that have been suggested that have not worked. I read that I should set the following to "false" to solve my problem. 1) keyword.enabled 2) browser.fixup.alternate.enabled 3) browser.urlbar.suggest.surches I have also gone into the settings menu and un-checked everything I could find about suggestions or words or anything else being added to the address bar. The only thing that should show up in and address bar is................you guessed it: AN ADDRESS! :-) Thanks so much for your help. I really appreciate the help. Mark

Chosen solution

You are getting dynamic search engine suggestions (magnifying glass icon at the left) as you type, even with "Provide search suggestions" being unchecked?

Or are they some other kind of suggestion such as search history (clock icon at the left) or a general suggestion about searching with a particular site?

Read this answer in context 👍 0

All Replies (6)

more options

Hi Mark, let me insert a picture here which I hope will help us communicate about exactly what you do NOT want to see in the address bar drop-down. This is from an older version, but hopefully is close enough for discussion:

Since you mentioned showing searches from your other bars, do you mean that you don't want to see search history entries in the drop-down?


Or if the problem is the cursor jumping from the search bar in the new tab page up to the address bar, that doesn't require changing the address bar search feature, it has its own preference. The hardest part is learning its name:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since I use this one myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Helpful?

more options

jscher2000,

Thank you so much trying to help me. I apologize for my ignorance.

Yes, the problem is the cursor jumping from the search bar in the new tab page up to the address bar. I do not want that to happen. And you fixed it!! Thank you so much!!

However, now when I type in the search bar in the new tab page I get search suggestions dropping down from the search bar. If you can help me get rid of that drop down from the search bar I would appreciate it.

Again, thanks for responding.

Helpful?

more options

You can turn off the dynamic search engine suggestions on the Settings page, search panel (Search suggestions in Firefox):

You'll probably still get a drop-down with the row of buttons to make it easy to switch among search engines.

Helpful?

more options

Thanks again for your reply. I'm still getting search suggestions under my search bar. I did uncheck the box on the settings page that says: Provide Search Suggestions. Actually I tried to uncheck all of the boxes there.

However, one of the lines says, "Show search suggestions ahead of browsing history in address bar results". That box will not "uncheck" for me. A check mark remains in that box even though I removed the check mark in the line that says: Provide Search Suggestions.

Could this be keeping me with search suggestions below my search bar even though it references the address bar and not the search bar?

Helpful?

more options

Chosen Solution

You are getting dynamic search engine suggestions (magnifying glass icon at the left) as you type, even with "Provide search suggestions" being unchecked?

Or are they some other kind of suggestion such as search history (clock icon at the left) or a general suggestion about searching with a particular site?

Helpful?

more options

Ok, I checked again and it is NOT with the hour glass. It looks like things I have searched for before so I guess that is search history. As you suspected, huh? So I suppose I can live with search history suggestions. They may come in handy. Thanks again for all your time and help. I love using computers, but I still have lots to learn. Blessings, mark

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.