Where did you install Firefox from? Help Mozilla uncover 3rd party websites that offer problematic Firefox installation by taking part in our campaign. There will be swag, and you'll be featured in our blog if you manage to report at least 10 valid reports!

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Woocommerce checkout card details input fields not loading on Firefox

  • 2 replies
  • 1 has this problem
  • 1 view
  • Last reply by yadontstop

more options

Hi,

I have 2 online stores built using Wordpress, both use the same theme, 'Storefront' and both using Woocommerce. The site with the issue, I am using a child theme.

Today I noticed the credit card input box on the checkout page is missing on the site with the child theme - the input fields aren't loading at all. (see screenshot) The issue only happens on Firefox and Firefox mobile. Everything displays on Chrome and Edge browsers.

I have deactivated all other plugins and checked after each one to see if the problem persists - it does. I have also tried using the Twenty Twnety-one theme to see if that makes a difference - it does not.

The site has previously been working and all boxes / input fields have been displaying properly until today.

If I inspect the element using FF console the document within the iframe is missing. Yet, when I use the console via Chrome or Edge it isn't (as expected becasue it displays on both browsers).

Any ideas as to why this behavour, will be appreciated - thanks.

Regards,


NOTE: I am using; Windows 7 / Android 8.0 FF 96.0.1 Chrome 97.0.4692.71 Edge 97.0.1072.62

Hi, I have 2 online stores built using Wordpress, both use the same theme, 'Storefront' and both using Woocommerce. The site with the issue, I am using a child theme. Today I noticed the credit card input box on the checkout page is missing on the site with the child theme - the input fields aren't loading at all. (see screenshot) The issue only happens on Firefox and Firefox mobile. Everything displays on Chrome and Edge browsers. I have deactivated all other plugins and checked after each one to see if the problem persists - it does. I have also tried using the Twenty Twnety-one theme to see if that makes a difference - it does not. The site has previously been working and all boxes / input fields have been displaying properly until today. If I inspect the element using FF console the document within the iframe is missing. Yet, when I use the console via Chrome or Edge it isn't (as expected becasue it displays on both browsers). Any ideas as to why this behavour, will be appreciated - thanks. Regards, NOTE: I am using; Windows 7 / Android 8.0 FF 96.0.1 Chrome 97.0.4692.71 Edge 97.0.1072.62
Attached screenshots

Chosen solution

I had another play around, it turns out it was an issue with MailPoet email signup slide in forms. Once I disabled them on the checkout page the card details input boxes loaded.

The issue only occurred on Firefox and no other browsers. I can only presume, FF load order is different to every other browser.

Read this answer in context 👍 0

All Replies (2)

more options

here is the checkout page > https://mnkcase.com/checkout

more options

Chosen Solution

I had another play around, it turns out it was an issue with MailPoet email signup slide in forms. Once I disabled them on the checkout page the card details input boxes loaded.

The issue only occurred on Firefox and no other browsers. I can only presume, FF load order is different to every other browser.