Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to disable ctrl+k keyboard shortcut?

  • 6 replies
  • 1 has this problem
  • 9 views
  • Last reply by cor-el

more options

For my work, I need to paste a lot of links into text (on a website which is probably somewhat poorly programmed), and when I select some text and hit ctrl+k to create a hyperlink, Firefox doesn't recognize that it's a text box and "takes over" the ctrl+k function, focusing on the search/address bar instead of allowing me to insert the link. (The reason I blame the website is that other websites, like Jira, work fine for this)

Is there a way to disable the ctrl+k functionality in firefox? I've seen a couple old threads on disabling various shortcut keys but I don't know what the "Focus Search bar" key would be called in either the Browser Console or configs.


Thank you!!

All Replies (6)

more options

I couldn't find a way to disable a single Firefox's shortcut.

But, give a try to this recommended extension because it may help you to copy and paste links.

1. Right-click on a tab > FoxyTab > Copy URLs > URLs All

It copies all the URLs of your current tabs, which you can later paste in a text box.

Hope it helps.

Modified by Charlie

Helpful?

more options

Charlie said

I couldn't find a way to disable a single Firefox's shortcut. But, give a try to this recommended extension because it may help you to copy and paste links. 1. Right-click on a tab > FoxyTab > Copy URLs > URLs All It copies all the URLs of your current tabs, which you can later paste in a text box. Hope it helps.

Thank you! I appreciate it. I'll probably use that since it looks pretty helpful in general for what i do all day.

Helpful?

more options

See also:

#
# Search Command Key Logic works like this:
#
# Unix: Ctrl+K (cross platform binding)
#       Ctrl+J (in case of emacs Ctrl-K conflict)
# Mac:  Cmd+K (cross platform binding)
#       Cmd+Opt+F (platform convention)
# Win:  Ctrl+K (cross platform binding)
#       Ctrl+E (IE compat)
#
# We support Ctrl+K on all platforms now and advertise it in the menu since it is
# our standard - it is a "safe" choice since it is near no harmful keys like "W" as
# "E" is. People mourning the loss of Ctrl+K for emacs compat can switch their GTK
# system setting to use emacs emulation, and we should respect it. Focus-Search-Box
# is a fundamental keybinding and we are maintaining a XP binding so that it is easy
# for people to switch to Linux.
#
    <key id="key_search" data-l10n-id="search-focus-shortcut" command="Tools:Search" modifiers="accel"/>

Helpful?

more options

seagull949 said

For my work, I need to paste a lot of links into text (on a website which is probably somewhat poorly programmed), and when I select some text and hit ctrl+k to create a hyperlink, Firefox doesn't recognize that it's a text box and "takes over" the ctrl+k function, focusing on the search/address bar instead of allowing me to insert the link. (The reason I blame the website is that other websites, like Jira, work fine for this)

It's complicated.

So first, as far as I know, there is no built-in setting to disable Ctrl+K from either moving the cursor to the classic small search box or to the address bar.

Second, we want the site to successfully intercept it and prevent it from reaching Firefox. It's obviously possible, as you can see if you type k into the Ad hoc testing box on my demo page here: https://www.jeffersonscher.com/res/keyvents.html

If the problem site was designed long ago, it's possible that it was programmed for a legacy behavior that Firefox later changed to conform to how other browsers work. There are a couple of preferences to revert key event changes for older sites. Since I'm only guessing at what the problem is, I'm not sure they will do the job in your case. Here's how you would try it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste ADDL and pause while the list is filtered

Firefox should show two preferences:

  • dom.keyboardevent.keypress.hack.dispatch_non_printable_keys.addl
  • dom.keyboardevent.keypress.hack.use_legacy_keycode_and_charcode.addl

Let's say your problem site is at https://www.example.com/editor

In that case, the host name of the site is www.example.com and we will enter that into the two preferences as follows:

(3) Double-click the first preference to display an editing field, and:

(a) If there is already a host name, add a comma at the end and position the insertion point at the end (b) Type or paste the host name of your problem site (c) Press Enter or click the blue check mark button to save the change

(4) Repeat with the second preference

Does that make any difference?

If you need to remove the exceptions later, simply double-click each preference to edit again.

Helpful?

more options

By the way, my reply assumed that Ctrl+K works on the site in other browsers. If the site simply doesn't support Ctrl+K at all in any browser, then you would need a different workaround.

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.