Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Browsec Ad infection

  • 1 reply
  • 1 has this problem
  • 8 views
  • Last reply by jscher2000

more options

frequently two of my installations of Firefox spontaneously open an advertisement window that says is from some place called BROWSEC. Since it is not caught by my two antivirus applications, it must be infecting the browser in some special way. Any hints on how to clean this out will be appreciated. Sample ad screen is attached.

Attached screenshots

Chosen solution

Is that a Firefox window? Usually if it's a new Firefox window, the Firefox icon on the Windows Taskbar will show a new thumbnail for that window (or if you have a lot, a new item on the list).

Here are a couple possibilities that come to mind if it's a Firefox window:

(1) These are popup windows triggered by websites

Your screenshot doesn't look like a popup window because the title bar and address bar are missing.

(2) These are windows/panels opened by an add-on

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Some malware-ish add-ons block/blank or otherwise interfere with using the Add-ons page. To bypass that, restart Firefox in its Safe/Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Is that a Firefox window? Usually if it's a new Firefox window, the Firefox icon on the Windows Taskbar will show a new thumbnail for that window (or if you have a lot, a new item on the list).

Here are a couple possibilities that come to mind if it's a Firefox window:

(1) These are popup windows triggered by websites

Your screenshot doesn't look like a popup window because the title bar and address bar are missing.

(2) These are windows/panels opened by an add-on

You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Some malware-ish add-ons block/blank or otherwise interfere with using the Add-ons page. To bypass that, restart Firefox in its Safe/Troubleshoot Mode. In that mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.