Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Fonts have an issue with being too thin and hard to read.

  • 5 replies
  • 1 has this problem
  • 109 views
  • Last reply by FredMcD

more options

My firefox browser has had issues displaying fonts when I have the "Allow pages to choose their own fonts, instead of your selections above" box checked. Its not all webpages as some have more bolded fonts, but it is more than one site.

I have scoured these forums trying to locate an answer, but for some reason the fonts are still so thin and unreadable. I have even erased all existence of firefox from my computer and reinstalled, but the issue still remains.

Please help me.

My firefox browser has had issues displaying fonts when I have the "Allow pages to choose their own fonts, instead of your selections above" box checked. Its not all webpages as some have more bolded fonts, but it is more than one site. I have scoured these forums trying to locate an answer, but for some reason the fonts are still so thin and unreadable. I have even erased all existence of firefox from my computer and reinstalled, but the issue still remains. Please help me.

Chosen solution

Please read the whole post. [v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".
Read this answer in context 👍 1

All Replies (5)

more options

Here is an example of what I see.

more options

Chosen Solution

Please read the whole post. [v56+] Type about:preferences#general<enter> in the address bar. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".
more options

Note that you appear to be running uBlock Origin, so make sure not to "block remote fonts" in UBO.

more options

Specifically the problem was uninstalling the helvetica font from my computer that fixed my issue. Thank you for the help. You have no idea how long this issue has plagued me for.

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems. Go to that post and click the 'Solved' button to its right.