Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot access any websites

  • 4 replies
  • 1 has this problem
  • 3 views
  • Last reply by jscher2000

more options

I get this when I go to any website, icluding Google, Facebook, etc: Warning: Potential Security Risk Ahead This is the message I got. It really seems unlikely that, as this message says, there is an issue with Google, Facebook, and the New York Times. Please advise--in simple English, as I am not a techie. THanks

===============

Warning: Potential Security Risk Ahead

Firefox detected a potential security threat and did not continue to www.washington.com. If you visit this site, attackers could try to steal information like your passwords, emails, or credit card details.

What can you do about it?

The issue is most likely with the website, and there is nothing you can do to resolve it.

If you are on a corporate network or using anti-virus software, you can reach out to the support teams for assistance. You can also notify the website’s administrator about the problem.

Learn more…

Someone could be trying to impersonate the site and you should not continue.

Websites prove their identity via certificates. Firefox does not trust www.washington.com because its certificate issuer is unknown, the certificate is self-signed, or the server is not sending the correct intermediate certificates.

All Replies (4)

more options

Hi, this means that the certificate Firefox received from the site did not test out as being valid. This can be caused by anything from the time set on the system to a "man in the middle" of your connection. So we suggest investigating in more detail before assuming that Firefox has lost its mind.

As a starting point, if you click the Advanced button on the error page, there should be

(A) An error code in ALL_CAPS that may help with diagnosis. See: How to troubleshoot security error codes on secure websites. Can you let us know what code you're seeing?

(B) A View Certificate link to open a new tab with information from the suspicious website certificate. The most interesting data usually is in the Issuer / Issued by section. For example, this might mention your antivirus or parental control software vendor. If you check several of your problem sites, do you notice a pattern to the issuer?

For example:

These are the Common Names I see under Issuer Name on those sites:

  • Google: GTS CA 1C3 (issued by Google Trust Services LLC)
  • Facebook: DigiCert SHA2 High Assurance Server CA (issued by DigiCert Inc)
  • NYTimes: Sectigo RSA Domain Validation Secure Server CA (issued by Sectigo Limited)

Helpful?

more options

Hi Jefferson

Thank you very much for the quick reply. This is all WAY over my head, but let me give you the info you requested.

Hmm, I had closed the browser after posting my query. When I re-started it, just now, I could get to those sites.

One possibility: Before I closed Firefox, I tried to make sense of some articles online. One said something about changing a proxy setting. I have no idea what that means, and it was not entirely clear, but I tried it. Perhaps that plus re-starting Firefox did the trick? Or perhaps that was just a coincidence.

I tried to return to that page to tell you what I had changed and whether it was the right thing to do (no idea), but I can't even find the place to make that setting now.

Where would I find proxy settings in firefox, and how should I set them? Do you suppose that might have been the fix?

Thank you very much! I am so glad that smart tech-savvy people like you help those of us who find all of this overwhelming.

All my best wishes, Robert

Helpful?

more options

When I tried using www.washington.com I got redirected to; Click here to buy washington.com for your website name.

Helpful?

more options

Hi Robert, several people have been solving secure connection problems by changing to the "No Proxy" setting. Unless you need a proxy server, No Proxy is a good setting.

It's in the Network Settings dialog. You can check that here:

  • Windows: "3-bar" menu button (or Tools menu) > Settings (previously "Options")
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. "No proxy" can work around connection issues caused by a proxy server intercepting browser connections at a system level.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.