Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Deleting item in dropdown window.

  • 5 replies
  • 1 has this problem
  • 15 views
  • Last reply by cor-el

more options

I have tried a hundred times and this method does NOT work.

open search. use down arrow highlight item press delete

Why is this so difficult?

Thank you.

All Replies (5)

more options

If you mean the address bar, there are two kinds of lists:

(1) Top Sites / Shortcuts list

This list appears when you click in the bar, before you type any text for Firefox to match off of. This is a read-only copy of the list on the built-in Firefox Home / new tab page.

To turn the list on/off, there is a "Top Sites" or "Shortcuts" checkbox on the Settings page. See: Address bar autocomplete suggestions in Firefox

To edit the list, use the steps in this article: Customize items on your Firefox New Tab page

(2) Bookmark/History/Open Tab suggestions

These may consist of any combination of bookmarks, history entries, and open tabs. You should be able to arrow down and Shift+Delete history entries. (Back in the day, it was just Delete, but now it's Shift+Delete as of I don't remember when.)

Helpful?

more options

No. At the library, my account number is in there. So are all of the mistakes. At a shopping website, the items I searched for before are in there. So is the one misspelling that will not garner any hits.

I should have been clearer the first time.

It used to be so simple.

Thank you.

Helpful?

more options

That sounds more like Form History (form and search history are stored together). Do you want to completely flush out the form history, or just delete selected items?

To delete selected items, arrow down and Shift+Delete may work if a plain Delete isn't working.

To completely flush form history, you can call up the "Clear Recent History" dialog (Ctrl+Shift+Delete). Carefully uncheck all of the boxes except "Form & Search History", change the Time Range to Everything, then click Delete.

Does that clear it?

Helpful?

more options

Always and only certain items.

I just tried highlighting with down arrow. Shift + delete doesn't work. Obviously, plain delete does not.

As I said earlier, it used to be so simple.

Not Mac...

Thank you.

Helpful?

more options

Suggestions in a drop down list with a key icon are suggestions coming from the Lockwise Password Manager and you need to remove them there.

You can rename/remove formhistory.sqlite in the Firefox profile folder with Firefox closed to remove all autocomplete data stored in the file.

You can use the button on the "Help -> More Troubleshooting Information" (about:support) page to go to the current Firefox profile folder or use the about:profiles page.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.