Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Old version of Firefox that allows plugins?

  • 3 replies
  • 1 has this problem
  • 16 views
  • Last reply by boomajang

more options

I am looking for the last version of Firefox that allows plugins. I have several older Foscam IP cameras and they work best with the browser plugin. However, Firefox doesn't allow this anymore and I really don't like any of the viewer clients. What I would like to do is download a portable version and possibly run it in a virtual machine so I can still use the latest version on the same machine. But this would allow me to use the old plugins and view my cameras.

Any ideas? Many thanks! Randall

All Replies (3)

more options

The old Firefox 52.9.0 ESR may be an option. https://portableapps.com/apps/internet/firefox-portable-legacy-52

Why do Java, Silverlight, Adobe Acrobat and other plugins no longer work? https://support.mozilla.org/en-US/kb/npapi-plugins

Modified by James

Helpful?

more options

I don't know if it is possible to run this plugin in the portable version.

Helpful?

more options

Thanks to both of you, I did end up downloading Firefox 50 x86 and installing it alongside my current version of Firefox and they remain distinct, thankfully. I assume because the old one is x86. As you say cor-el, it did not work in the portable version which is what I tried first. But I am really happy this worked out. It's been a while since I have been able to use the cameras and it was becoming an issue. Thanks again! Randall

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.