Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Ubuntu 18.04.5 - tab flickering when I refresh or loading website

more options

Dear Mozilla Support,

After some update (I think from 89.0.0 version of Mozilla Firefox - this version with new looks of tabs) I notice flickering on the tab when I loading website or refresh website. This looks very strange. Like I said I dindn't notice any issue with flickering on previous Mozilla Firefox versions. Only with these new versions with new look of the tabs. I didn't remember if it was 89.0.0 version or 90.0.0 version. I don't know if it is problem with the machine but I didn't notice this issue on another computer with 90.0.2 Firefox version but with Windows 10 OS. I also noticed this issue with Firefox 90.0.0.2 with Windows 7 OS on another computer so I don't know if this is problem with two computers or Firefox itself. Can you help me?

Yours faithfully, Piotr

Chosen solution

This could be a problem with WebRender or hardware acceleration in Firefox.

You can try to disable WebRender by setting this pref to true on the the about:config page to see if that has effect.

  • gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 2

All Replies (8)

more options

A video showing the issue would help.

Helpful?

more options

Chosen Solution

This could be a problem with WebRender or hardware acceleration in Firefox.

You can try to disable WebRender by setting this pref to true on the the about:config page to see if that has effect.

  • gfx.webrender.force-disabled = true

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Helpful?

more options

I tried safe mode and I thinked that issue was gone but I tested today more and I noticed that issue is still here. I also tried turn off hardware acceleration but this not help me. I didn't test yet option "gfx.webrender.force-disabled = true " but I think that this also will not help. I am worry about this because this looks strange. Like I said I only have problem with flickering tab when I refresh or loading website, for example: allegro.pl. This is not visible always. I tested for 10 minutes and I noticed twice flicker so now is it very rare but exist. This is randomly and sometimes this is more often.

P.S. I also deleted firefox files where are located profiles so my browser was reset to factory default settings but this not help.

Modified by Peter

Helpful?

more options

Dear Mozilla Community,

I solve this issue or last update for 91.0 version fixed this issue. Now I will tell you what I did:

1) I tried delete all files in .mozilla directory. Like we know in this location are stored all settings for profiles. This didn't help. 2) I tried run Mozilla Firefox in safe mode. This helps because in this mode I didn't notice this issue. When I run again in "normal" mode this issue was back. 3) I tried gfx.webrender.force-disabled = true in about:config like said user @cor-el. I don't know if this was help because I use it now and I don't notice issue ony my machine with Ubuntu 18.04.5. On Windows 7 machine I also tried change configuration in about:config and this looks like this also helps. After update to 91.0 I returned back to gfx.webrender.force-disabled = false and now this also works fine without issue.

Someone can tell me what cause of this issue was? If I changed settings in about:config like above and only changed from gfx.webrender.force-disabled = false to gfx.webrender.force-disabled = true and now get back to gfx.webrender.force-disabled = false this restores all settings to default or this option change also some other option automatically? Can you tell me?

Helpful?

more options

I had the same problem on Win 7 Enterprise after update 90.0.2 and gfx.webrender.force-disabled = true solved my problem too.

Helpful?

more options

Note that in Firefox 93 it will no longer be possible to disable WebRender. To prepare for that gfx.webrender.force-disabled is renamed to gfx.webrender.force-legacy-layers in Firefox 92.

  • 1725388 - Remove/change environment variables and prefs that can disable WR

Helpful?

more options

@cor-el What did you mean that in Firefox 93 will be no longer possible to disable WebRender? Is it mean that if I will be have this same problem I will can not resolve this by this option? If yes what similar option will be in Firefox 93?

I don't know what problem existed in mine two machines (one with Ubuntu and second with Windows 7) but I turned off hardware acceleration on both computers and this didn't help. Only option gfx.webrender.force-disabled = true in about:config helped me. What changes did option made in firefox? Can you explain me?

Modified by Peter

Helpful?

more options

OK, the problem appeared again. The version now is 93.0, 64-bit, OS - Windows 7 Enterprise. It seems that the problem appears once I open more than 4 tabs, otherwise there is no problem. None of the previous settings change the behavior, nor turning off the Hardware acceleration helps. I wonder if I should stop auto-updating firefox and downgrade to the previous version. I am curious what the problem is exactly and what makes this to happen. As I read the web rendering can't be deactivated anymore, but what at all does it make and why this problem occurs, I don't have any idea. Hopefully someone will give us a clue what the problem is.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.