Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 90.x causing 5C temperature increase in CPU

  • 3 replies
  • 1 has this problem
  • 12 views
  • Last reply by Al

more options

Firefox 90.x (when opened - all cache clean, all history etc clean) causes temperature of mac to increase from 32 to 37C without actually doing anything. When browsing (without plugins) normal new sites, temperature increases to 40C.

How can I DOWNGRADE to v 89.x without losing info? Thank you.

Chosen solution

Got the solution:

In "Preferences-->General" scroll to "Performance":

Click on "use recommended performance settings" (if ticked), then untick any of the subsidiary settings in turn; complete this by finally re-ticking the "use recommended performance settings" box.

If presented instead with "use hardware acceleration" and (1-8), just untick that, and complete this by (only ONCE) ticking the "use recommended performance settings" box.

Temperature now reduced.

Read this answer in context 👍 0

All Replies (3)

more options

Hi AI,

Step 1: Download an Older Firefox Build 1. Open the Firefox directory listings on the web browser. 2. Scroll to the version of your choice and select it. You should now see various builds of Firefox, corresponding to your OS. 3. Choose the directory per your system configuration. (say, Windows) Furthermore, under Windows, you will see two different architectures*, 32 bit and 64 bit. 4. Select the one that matches your CPU architecture. 5. Select your language and region. As for this guide, we are choosing English US, so it translates to en-US. 6. Finally, download the .exe file corresponding to your selected version.

Step 2: Install the Older Version of Firefox

Now that the older version has been downloaded in local storage. We can proceed to install and overwrite the older version. 1. Double click on downloaded .exe file to launch the setup file. 2. Click on the Next in the welcome screen and then select the setup type, out of Standard or Custom. 3. It will now scan for the installation directory and will bring up the location where the existing version is stored. 4. You just have to hit the Upgrade button and wait for the process to complete. That’s it. You have successfully downgraded to an earlier build of Firefox. Now there’s just one thing left to do- disable its Auto-Updates feature.

Step 3: Disable Automatic Updates

1. Launch the Firefox Browser on the computer. 2. Click on the horizontal menu button situated at the extreme right. 3. Select Options from the menu list. 4. Scroll to the Firefox Updates section, and select Check for Update but let you choose to install them. This will disable the automatic updates on the Firefox browser. Though this will check for the newer version, but won’t install unless you manually confirm to update.

  • It’s not recommended to stay on the older version for a long, it can happen that successive versions might have the fix or patch release for the issue you are facing. Hence, keeping your Firefox browser up to date is highly recommended.

Also Read: https://browserhow.com/how-to-downgrade-and-install-older-version-of-firefox/

Helpful?

more options

Thank you, but this (windoze) solution does not solve it for that I have tried the Mac version already. The problem is that the machine runs 5C hotter without having changed any of the systems settings (unfortunately, I only clicked on the update this morning - with automatic updates already selected as "...let me choose to install...").

Regards

Helpful?

more options

Chosen Solution

Got the solution:

In "Preferences-->General" scroll to "Performance":

Click on "use recommended performance settings" (if ticked), then untick any of the subsidiary settings in turn; complete this by finally re-ticking the "use recommended performance settings" box.

If presented instead with "use hardware acceleration" and (1-8), just untick that, and complete this by (only ONCE) ticking the "use recommended performance settings" box.

Temperature now reduced.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.