Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't get Firefox to remember my pdf preferences (always asks "What should Firefox do?") [Big Sur]

  • 1 reply
  • 1 has this problem
  • 2 views
  • Last reply by jscher2000

more options

Hi guys,

I've been trying for a couple weeks to make the switch from Chrome on Big Sur but am having trouble ironing a few things out. I work in research and view a ton of pdfs, so I like them to (1) open in browser, and (2) specifically, open in a new tab. I haven't been able to get Firefox to do these things.

For (1), I get the "What should Firefox do with this file?" every time I download a pdf from Researchgate (even the same exact pdf). I select the options in the image ("open with Firefox (default)" and "do this every time." But it shows me the popup every time. I've gone to Preferences->Applications->PDFs->Open in Firefox but the behavior persists.

For (2), I'm at a loss - when I open downloaded pdfs, they always open in a new window. I don't even know if it's possible to get them to open in a new tab, but it would be nice and save me a lot of time.

Thanks in advance if anyone can point me in the right direction!

Attached screenshots

All Replies (1)

more options

Welcome! Firefox will follow your instructions on the Settings page for Portable Document Format (PDF) -- more info on how to set that in View PDF files in Firefox or choose another viewer -- if two conditions are met:

(1) The server sends Firefox this header:

Content-Type: application/pdf

If the server sends a different content-type, Firefox usually won't match it up with the saved instructions for application/pdf.

(2) The server does NOT send Firefox this header:

Content-Disposition: attachment

This triggers the download dialog. Every. Single. Time.

This second behavior appears to be the issue with your example file.


I have an add-on to work around these two problems. You can install it from the Mozilla Add-ons site:

https://addons.mozilla.org/firefox/addon/content-type-fixer/

To activate it, click its Zzzz button on the toolbar to wake it up. That should take care of #1 automatically. To solve #2, click the button again and in the Content-Disposition Override section of the menu, click "Follow my settings (inline)".

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.