Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to unblock facebook comments plugin on FF 89?

  • 2 replies
  • 1 has this problem
  • 66 views
  • Last reply by Valso

more options

Some websites have this text box under their articles to write a comment and post it on Facebook (see the screenshot). But for that to happen, first you must login to your Facebook account. The problem is that when I click the button "login to post", nothing happens - as if I didn't click it at all. I suspect the reason for that are the integrated anti-tracking options in Firefox 89. So the question is: how do I get this plugin to work in Firefox 89?

P.S. Until a month ago I was temporarily using Chromium as default browser and there the FB plugin had no issues. Chromium has no anti-tracking options which is why I think this function in Firefox is the reason for the FB plugin not to work.

Some websites have this text box under their articles to write a comment and post it on Facebook (see the screenshot). But for that to happen, first you must login to your Facebook account. The problem is that when I click the button "login to post", nothing happens - as if I didn't click it at all. I suspect the reason for that are the integrated anti-tracking options in Firefox 89. So the question is: how do I get this plugin to work in Firefox 89? P.S. Until a month ago I was temporarily using Chromium as default browser and there the FB plugin had no issues. Chromium has no anti-tracking options which is why I think this function in Firefox is the reason for the FB plugin not to work.
Attached screenshots

Chosen solution

Thanks, Fred. Stored cookies and cache are not the problem bc I clear them on a regular basis. But the other two links gave me an idea what might be blocked and led me to the solution - social media cookies were blocked. Once I unblocked these, the plugin worked the way it was intended.

Read this answer in context 👍 0

All Replies (2)

more options

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

more options

Chosen Solution

Thanks, Fred. Stored cookies and cache are not the problem bc I clear them on a regular basis. But the other two links gave me an idea what might be blocked and led me to the solution - social media cookies were blocked. Once I unblocked these, the plugin worked the way it was intended.