Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

This thread was closed and archived. Please ask a new question if you need help.

All of a sudden my bookmarks are double spaced, what happened ?

  • 26 replies
  • 8 have this problem
  • 4643 views
  • Last reply by Chris Ilias

more options

All of a sudden, my bookmarks ( and other bookmarks) are double spaced. This just happened today and I didn't make any changes. How do I get rid of the double spacing ? Thank you.

All of a sudden, my bookmarks ( and other bookmarks) are double spaced. This just happened today and I didn't make any changes. How do I get rid of the double spacing ? Thank you.

Chosen solution

This wider menu item spacing is a feature of the Firefox 89 "Proton" redesign.

I can give you a quick short-term workaround, but a more durable solution will require more work.

Temporary Fix -- for Firefox 89-90 ONLY

For testing purposes, the developers left a preference in Firefox 89 to switch between new style and old style menus:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.contextmenus.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

Some menus may be cut off or sized incorrectly after this change until the next time you do a normal exit/restart of Firefox.

WARNING: There are plans to remove this preference in the next two months The preference setting was created as a toggle for developers when building the new design. Now that the new interface has shipped, the preference will be removed.

If you have any issues with the new design, please let us know what it is you don't like, and we can try provide more permanent solutions depending on the issue.


Longer Term Community Workaround

This involves setting up a userChrome.css file. The full instructions are in the following thread: https://support.mozilla.org/questions/1337841

Now further down in this thread: #answer-1434499

Read this answer in context 👍 6

All Replies (20)

more options

Chosen Solution

This wider menu item spacing is a feature of the Firefox 89 "Proton" redesign.

I can give you a quick short-term workaround, but a more durable solution will require more work.

Temporary Fix -- for Firefox 89-90 ONLY

For testing purposes, the developers left a preference in Firefox 89 to switch between new style and old style menus:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste browser.proton.contextmenus.enabled and pause while the list is filtered

(3) Double-click the preference to switch between true (new style) and false (old style)

Some menus may be cut off or sized incorrectly after this change until the next time you do a normal exit/restart of Firefox.

WARNING: There are plans to remove this preference in the next two months The preference setting was created as a toggle for developers when building the new design. Now that the new interface has shipped, the preference will be removed.

If you have any issues with the new design, please let us know what it is you don't like, and we can try provide more permanent solutions depending on the issue.


Longer Term Community Workaround

This involves setting up a userChrome.css file. The full instructions are in the following thread: https://support.mozilla.org/questions/1337841

Now further down in this thread: #answer-1434499

Modified by jscher2000 - Support Volunteer

more options

It worked !! Thank you.

more options

Thanks for the report back.

This is a temporary preference that may stop working next month, so we'll come back to "Plan B" later.

more options

I used to be able to see all my bookmarks menu on one page. Now I have to scroll down. It's annoying and pointless. I wish I could go back to Firefox before the last "update".

more options

Since Firefox seem to have decided that I must have double spacing whether I like it or not, I will switch to Opera who let me see my bookmarks the way I want to and not they way they want.

more options

malcolmdale said

Since Firefox seem to have decided that I must have double spacing whether I like it or not, I will switch to Opera who let me see my bookmarks the way I want to and not they way they want.

Does this mean the setting change didn't work for you?

more options

Same problem for me. I have lots of bookmarks and am having to scroll and scroll. It is very, very irritating. The temp fix sounds complicated and anyway is going to vanish in a month or so. I shall have a look at Opera to see if it suits me better. Shame as I have been with Firefox for ever.

more options

bob246 said

The temp fix sounds complicated and anyway is going to vanish in a month or so.

I think it's a good idea to become a little bit familiar with about:config so you can have more control over your experience in Firefox, even if various of these preferences come and go.

more options

The about:config solution worked for me. Thank you for the help.

more options

Hi,

  This is a massive problem for me. I have hundreads of bookmarks and folders that I use for research and now when I'm using my laptop the screen is filled with nothing but bookmark lists. It wastes my time and is quite annoying. It's enough to make me change browsers if it doesn't change.
  I hope those who are responsible for desiging the interface change this bad change as soon as possible.

Steve

more options

Thanks for this fix! This was super annoying. And like the other commenter said, if this happens again and can't be fixed any longer I will be forced to change browsers.

Modified by ShaqFu

more options

I do not use Firefox in order to be told to dig into config to fix a situation I did not ask for (bookmark double-spacing) and which should be an easy toggle (single or double) setting. Will give you a month for an easy, lasting fix, and, if not forthcoming, move to another browser.

more options

I have tried both the about:config/contextmenus/false and userChrome.css and neither works. I don't like having to scroll through MY bookmarks. It also looks like I am not the only user unhappy with this "upgrade"! Please supply a permanent fix.

more options

jscher2000 said

malcolmdale said

Since Firefox seem to have decided that I must have double spacing whether I like it or not, I will switch to Opera who let me see my bookmarks the way I want to and not they way they want.

Does this mean the setting change didn't work for you?

I don't think I can waste a lot of time trying to do this Chrome fix when you say it will only be a temporary fix. I solved the problem myself by downloading the previous Firefox and the only annoying thing now is I get a pop-up every day telling me a New Firefox is available and I have to click "not now".

more options

malcolmdale said

I don't think I can waste a lot of time trying to do this Chrome fix when you say it will only be a temporary fix.

Setting up a userChrome.css file with rules to directly style the menus is completely independent of the temporary preference. Your file will keep working until Firefox modifies the way the menus are coded so much that the rules stop working, at which point you would need an update to the code in your userChrome.css file.

I'll edit the earlier post to clarify that.

more options

This temp fix worked. I have thousands of bookmarks organized into a hundred folders. This change of theirs means I have to waste twice the time scrolling through them, dozens of times a day, 365. Grrrr

more options

Firefox 91 update messed up my menus by double spacing browser.proton.contextmenus.enabled is still set to false but seems to have no effect

Please allow us to go back to single spacing.

more options

j_lindley said

Firefox 91 update messed up my menus by double spacing browser.proton.contextmenus.enabled is still set to false but seems to have no effect

That's correct, the preference actually doesn't exist any more (you'll see a trash can at the end of the row for that preference indicating it's no longer a standard built-in preference).

At this point, there is no built-in setting to change the spacing of menu items.

Unofficial Community-Supported Workaround

Firefox users can modify the user interface of the browser using custom style rules. This involves setting up a userChrome.css file. If this is your first time, make sure to set aside 10 quiet minutes to work through it.

(For anyone who already has a userChrome.css file set up, you just need to add the rule under (A) to your file.)

Menu Spacing

(A) Select and copy the following style rule code

/*** Tighten up drop-down/context/popup menu spacing ***/

menupopup > menuitem, menupopup > menu {
  padding-block: 4px !important;
}
:root {
  --arrowpanel-menuitem-padding: 4px 8px !important;
}


Some users consider that 4 pixels of space above and below items is still too spacious and prefer a lower value. For example, for 2 pixels of space, change 4px to 2px in both rules. Check the screenshot illustrating the differences between these amounts of padding for reference. (Keep the 8px as it is, that refers to left side and right side padding.)

(B) Generate and download a userChrome.css file

Open the following page and paste the above rules into the editor, replacing the sample rule:

https://www.userchrome.org/download-userchrome-css.html

Then click "Generate CSS File" and save the userChrome.css file to your computer. (See second attached screenshot)

Use the downloads list on the toolbar to open the downloads folder directly to the new userChrome.css file. (See third attached screenshot)

Minimize that file browser window for later reference.

(C) Create a new chrome folder in your profile folder

The following article has the detailed steps for that (#1, #2, and I recommend #3)

https://www.userchrome.org/how-create-userchrome-css.html

I have videos for both Windows and Mac in case the text is not clear.

(D) Move the userChrome.css file you generated in Step B into the chrome folder you created in Step C

(E) Set Firefox to look for userChrome.css at startup -- see step #6 in the above article.

The next time you exit Firefox and start it up again, it should discover that file and apply the rules.

Success?

I suggest bookmarking any thread you get userChrome.css code from for future reference (in case the rule stops working).

Modified by jscher2000 - Support Volunteer

more options

In Firefox 91+ you can no longer disable Proton via "browser.proton.enabled = false" on the about:config page. Best is to leave browser.proton.enabled at its default true value as the false setting can cause issues.

In Firefox 91+ you need to use code in userChrome.css to override changes coming with the Proton design.

more options

As you said, the about:config fix no longer works. But why on earth did they do this? What possible advantage could it have? Any long term user such as myself is now seriously inconvenienced. Please revert. Can this issue be reported any other way?

  1. 1
  2. 2