Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

how to stop programmable search engine, sometimes it opens up automatically ?

  • 1 reply
  • 2 have this problem
  • 5 views
  • Last reply by jscher2000

more options

fix my problem

Attached screenshots

All Replies (1)

more options

Hi, how did you get to that page? For example, did this open from a specific website's search box, or did you search from Firefox's address bar?

You can start by checking whether your search engine has changed from the built-in Google search to a different one. See: Change your default search settings in Firefox.

If you cannot control that setting, or searches still use the Google Custom Search, one possible culprit would be an extension. You can view, disable, and often remove unwanted or unknown extensions on the Add-ons page. Either:

  • Ctrl+Shift+a (Mac: Command+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, or privacy, or looks suspicious or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Note: if the Add-ons page is blank or inaccessible:

Use Firefox's Safe/Troubleshoot Mode to temporarily deactivate extensions.

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Can you regain control of your searches?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.