Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox on macOS 11.2.3 (20D91) enters dark-mode, but won't leave.

  • 7 replies
  • 1 has this problem
  • 7 views
  • Last reply by TerryN21

more options

Hello altogether. I sat up my MacBook to automatically enter light or dark mode. Firefox enters dark mode as expected but won't leave. Even if I restart the MacBook the next day, while the system boots with light mode enabled, Firefox will remain in dark mode.

To change this temporarily, I have to open the macOS settings and enable light mode. Firefox now change to light mode and stays in light mode, even if I again re-enable the automatic changing in the macOS settings.

Later those days, Firefox enters dark mode as expected but won't leave, like described before.

Is this a known bug? Anything else I can try?

Thanks for reading, looking forward to a possible solution.

All Replies (7)

more options

Anyone here with any idea to this question? Nearly any suggestion is appreciated.

In between I figured out, that FF enters dark-mode, while the device is running, but won't leave if I shut down late and restart next day (what is my usual behavior). If the device is running over-night, FF leaves dark-mode if I wake up the device next morning. But, as written before, I always shut the device down, save battery and have a fresh start each day.

Thanks for reading!

Helpful?

more options

Anyone here with any idea to this question? Any suggestion is appreciated.

Helpful?

more options

Sad to say, it appears to be a bug: https://support.mozilla.org/en-US/questions/1264027

Helpful?

more options

@TerryN21 thanks for the reply and that link! If I read that right, it's from 2019. It should‘ve been fixed in between.

Helpful?

more options

It hasn't been fixed but it isn't the same as your issue, well, not originally. The person who filed the bug report wanted Firefox to use its own scheme rather than the system scheme. You may be able to chop and change with an about:config setting (which you may have to create): ui.systemUsesDarkTheme — Set to 0 for light and 1 for dark. You would need to restart the browser. There's another setting which you may need to change as well: https://support.mozilla.org/en-US/questions/1271928

Helpful?

more options

Thanks again! For such a config-setting I select a light- or dark-appearance. I think this won't change when light- to dark-mode changes automatically?

Helpful?

more options

No, you would be changing it yourself.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.