Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How can I get the "old" address bar functionality back?

  • 4 replies
  • 1 has this problem
  • Last reply by Mathius

more options

Ok, so like the title says.. Years ago, Firefox changed from having the normal "File Edit View History" etc. as the default interface and tried to streamline everything into icons. I have no idea why. Maybe it had something to do with the mobile version. With a few customizations I was able to get the old look back, with my address bar.

Then a while back the address bar changed. It used to be that the address bar had a drop down that listed the sites you used most frequently. At some point mine just sortof froze and only lists the same 8 sites. Except its worse because 2 of them are now searches for Google and Amazon and not even the original google or amazon web pages. I cannot delete pages from this list like I could in the past, either.

Also, you could, you know... put an address in the address bar and it would take you directly to that site. Now it tries to do a search just as often as it actually takes me to the correct site.

This forcing search engines baffles me, because there's an actual search bar, right directly next to the address bar by default.

So if someone could help me understand how I can change my address bar back to being an address bar, that would be a great help to me. Second, if I could fix the drop down of sites to either be my most frequent sites, or a list of sites I add manually, that would be great also.

All Replies (4)

more options

If you want a dropdown list in the address bar, you are to a degree using it for search. I open most sites I want from bookmarks or search results (for which I use the search bar). All I ever enter in the url-bar is an url or (in the case of a new tab) a domain name. Perhaps you should start with "Clear Recent History" (ctl+shft+del). You could then enter about:config in the url-bar (I suggest a new tab), elect to proceed when you get a warning then find and change the following setting to 'false': keyword.enabled I have the following setting also marked 'false': browser.urlbar.oneOffSearches You may have to add that setting.

Helpful?

more options

Of course I have bookmarks, I also have a few tabs pinned as well as certain tabs I just leave open all the time. The drop down in the address bar was a quicker and convenient list... Look at it as "most used Bookmarks."

If I wanted to do a search, I'd use the search box. That's what it's for.

More to the point, the address bar USED to work in the way I'm describing in my first post. The address bar should be for a web address. The search box for searches. This is common sense.

So the keyword.enabled setting you're describing sounds like it turns off autocomplete. Is that not what it does?

I set browser.urlbar.oneOffSearches to False, but it seems to make no difference. In fact I have noticed that just opening a new tab, the cursor defaults to the url/address bar, and immediately drops open a box asking to search bing (my preset default search engine.) I have found quite a bit of complaining on google and bing about this feature, but nothing as to how to get rid of it.

Modified by Mathius

Helpful?

more options

Mathius said

Ok, so like the title says.. Years ago, Firefox changed from having the normal "File Edit View History" etc. as the default interface and tried to streamline everything into icons.

You can have the menu bar back if you like. Tap the Alt or F10 key to activate it temporarily, then

View > Toolbars > Menu bar

It used to be that the address bar had a drop down that listed the sites you used most frequently. At some point mine just sortof froze and only lists the same 8 sites. Except its worse because 2 of them are now searches for Google and Amazon and not even the original google or amazon web pages. I cannot delete pages from this list like I could in the past, either.

Firefox 75+ shows Top Sites from the new tab / Firefox Home page when you click in the bar, before you start typing anything for Firefox to match. You have choices:

(1) Make this list more useful by curating your Top Sites on the new tab page

More info: Customize items on your Firefox New Tab page

(2) Turn off this feature so that nothing drops down automatically when you click in the bar

Uncheck the Top Sites box in the Address Bar section of the Options page:

https://support.mozilla.org/en-US/kb/address-bar-autocomplete-firefox#w_how-can-i-control-what-results-the-address-bar-shows-me

Note: if you type a space in the bar, Firefox should show the old "frequently visited pages" list.

Also, you could, you know... put an address in the address bar and it would take you directly to that site. Now it tries to do a search just as often as it actually takes me to the correct site.

What are you entering in the bar? Firefox switched how it handles single words: instead of doing a DNS lookup first, it does a search first. Otherwise, if it looks like an address, Firefox should go to that address.

Helpful?

more options

jscher2000 said

Mathius said

Firefox 75+ shows Top Sites from the new tab / Firefox Home page when you click in the bar, before you start typing anything for Firefox to match. You have choices:

(1) Make this list more useful by curating your Top Sites on the new tab page

More info: Customize items on your Firefox New Tab page

Ok, I will look into customizing my new tab. This is an acceptable workaround. I have noticed, although it isn't a big deal, very often when the drop down shows these "new tab" items, it often screws up the icons completely.

Note: if you type a space in the bar, Firefox should show the old "frequently visited pages" list.

That's how it used to work by default without having to hit space, but again, at least I know how to do that now.

What are you entering in the bar? Firefox switched how it handles single words: instead of doing a DNS lookup first, it does a search first. Otherwise, if it looks like an address, Firefox should go to that address.

Yes, this is an issue for me. It should prioritize DNS first. I wish I could remember the site, but I was trying to go to a site last week and I could not get it to direct me to the site at all. It just kept doing a search and I was never able to go to the site. It was sending me to something with a similar name. I wish I could remember which site it was.

Modified by Mathius

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.