Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Preference settings automaticly change

  • 2 replies
  • 1 has this problem
  • 22 views
  • Last reply by arthur907

more options

I have Firefox 87 installed on my Mac computer. I set my home page to Parler.com and my search engine to DuckDuck.com. My setting stay like this for Two or Three times when opening Firefox but then my setting automaticly change to (searchmarquis/searchBaron.com for my homepage and my search engine changes to Goggle .com. When I go back into Fiirefox perferences the only search engine available is Goggle.com. this is the 10th and last time of having to reset my perferences in Firefox. Why6 is this happening and how can I stop it???

All Replies (2)

more options

Hi, sorry to hear about the "hijacking." If Firefox shows it plans to send a search to Google (this usually shows in the bar below the search box) but you get a results page from a different site, this kind of in-flight redirection usually is caused by either an add-on or by external malware. You didn't share your extensions list while posting your question, so here's how to check for problem extensions on your Firefox:

Open the Add-ons page. Either:

  • Command+Shift+a (Windows: Ctrl+Shift+a)
  • "3-bar" menu button (or Tools menu) > Add-ons
  • type or paste about:addons in the address bar and press Enter/Return

In the left column of the Add-ons page, click Extensions. On the right side, find the "Manage Your Extensions" heading.

If there is at least one extension before the next heading -- "Recommended Extensions" -- please continue:

Then cast a critical eye over the list below that heading. Any extensions Firefox installs for built-in features are hidden from this page, so everything listed here is your choice (and your responsibility) to manage. Anything that mentions search, or privacy, or looks suspicious, or that you just do not remember installing or why? If in doubt, disable (or remove). For your privacy and security, don't let mystery programs linger here.

Any improvement?

If your Add-ons page is blank or is blocked, you can restart Firefox in its Safe Mode to do the above review:

In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to bypass issues that can cause problems with pages.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Can you regain control of your searches?

Helpful?

more options

This searchbaron / searchmarquis problem has been around for months and impacts not only Firefox but also Bing, Safari, etc. I'm on MacOS and searched high and low with the ActivityMonitor to find the malware process with NO success. Other suggestions are welcomed.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.