Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox won't open anything

  • 1 reply
  • 1 has this problem
  • Last reply by jonzn4SUSE

more options

Firefox 87.0 (64-bit) on Ubuntu 20.10 is currently unusable as it won't open anything.

  • Firefox opens with no page loaded.
  • Clicking the single "getting started" bookmark does nothing.
  • Entering a search term in the address bar and pressing 'enter' changes the url in the address bar but nothing is loaded and the page remains blank. There is no indication that anything is loading.
  • Entering a url, such as "", and pressing "enter" does nothing. There is no indication that anything is loading.
  • Opening the menu by clicking on the burger icon, then on "preferences" does nothing except make the menu disappear (same with most of the options in the menu).

In the browser console I see some errors and no request info (see screenshot).

I've tried `sudo apt purge firefox` then installing again, which didn't help. The problem started with ubuntu 20.04 (I only updated to 20.10 to see if it might resolve this problem).

I've tried the "refresh firefox" option, starting in safe mode, and clearing the startup cache, which didn't help.

Any suggestions would be much appreciated.

Attached screenshots

All Replies (1)

more options

Do you have the same issue with other users on that machine? Can you try downloading Firefox to a folder and running it from there?

Also, how about seeing what strace can show for the Firefox process after you try a site.