Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When using firefox brower websites corrupted

  • 6 replies
  • 2 have this problem
  • Last reply by FredMcD

more options

When I go to websties using firefox the pages are corrupted, have strange charaters interspersed on the page, refresh do not clear it up

Chosen solution

Works perfectly in Safe Mode, I disabled graphics hardware accelerator and that may have fixed it?

Read this answer in context 👍 0

All Replies (6)

more options

Is this with all websites/pages, some, a few?


In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Thank you!


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

If there is still a problem, Start Firefox in Safe Mode {web link} by holding down the <Shift> (Mac=Options) key, and then starting Firefox.

A small dialog should appear. Click Start In Safe Mode (not Refresh). Did this help?

While you are in safe mode;

Try disabling graphics hardware acceleration in Firefox. Since this feature was added to Firefox it has gradually improved but there are still a few glitches.

How to disable Hardware Acceleration {web link}

Helpful?

more options

I think I have uploaded a screen shot. Corruptions occurs on many websites using Firefox, but does not occur when using the Edge browser.

Helpful?

more options

Chosen Solution

Works perfectly in Safe Mode, I disabled graphics hardware accelerator and that may have fixed it?

Helpful?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Helpful?

more options

Thanks you FredmcD, brought Foxfire up in the Safe Mode, work fine, Per you rec I then disabled graphics hardware accelerator and that looks like it fixed it. This forum save the day, was not able to get it fixed by just searching via Google. thanks much

Helpful?

more options

Glad to help. Safe Surfing.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.