Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

When cache passes 400, Firefox slows down

  • 5 replies
  • 1 has this problem
  • 20 views
  • Last reply by jscher2000

more options

Firefox always up-to-date MacBook Air (125 TB mem) always up-to-date (5 yrs old, otherwise working perfectly). Mostly browsing social media, blogs, newspaper articles. (video streaming causes no cache problems and are generally unaffected by slow Firefox performance)

If I'm not working and doing many hours of browsing daily, I have to clear my cache 5-6 times a day, after every couple of hours. In the older Firefox, this was easier because "cache" and "cookies" were separate actions, so in three clicks (preferences, cache, clear) I could be browsing again. But in recent versions, the clear cache is now a longer process (preferences, privacy, cache, uncheck cookies, clear), then I can get back to browsing. (This seems to be a trend with a lot of new software engineers, making steps longer instead of shorter, mind boggling.)

I've already read some "answers" here that claim that clearing the cache "should" not improve performance. This is silly. Thousands of us are constantly forced to manually clear our cache to be able to use Firefox. It's tiring, and gaslighty, but I continue with Firefox because I believe in the community principles of Firefox, but instead of improvements, every update just brings more and more dysfunction). Firefox's cache not self-managing is such a huge problem that there's a dozen extensions for cache clearing, but since my last Firefox reset, I can no longer find the one I liked, and the new cache clearing extensions don't perform so well, so it's back to preferences-manual-cache clear.

Symptoms: -Page loads slow or stall -Twitter feed bounces to top of page (even with accessibility-Reduce Motion-setting) -Facebook group members list page bounces to top -Facebook post history browsing slows to a crawl (made worse by fb having removed its time selection tools, so now to see a historical post, we must scroll, scroll, scroll, scroll, and Firefox eventually just stalls out) -Logins fail That's when I head over to my cache, see it's above 400 or sometimes above 500, un-click cookies (which I sometimes delete too, any time the cookies are over 100, even though I'm set to minimal cookie retention, I delete all cookies older than a week), CLEAR CACHE, then Firefox performs correctly... for a couple of hours anyway.

In theory, Firefox cache is supposed to "self-clean" of the old stuff? but I have not seen that in practice. Since this is a problem for so many people, why doesn't Firefox create an easy button to clear only the content we want, instead of total wipe? (I also reset my Firefox entirely 3-4 times a year, but I hate doing this as so many preferences get lost)

Modified by TNT666

All Replies (5)

more options

Caches were invented in the days of dial-up network connections. With speedy connections, disk access speed could be a bottleneck.

Would it help to cap the disk cache size at a lower level? You could try this:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste cache.disk and pause while the list is filtered

(3) Double-click the browser.cache.disk.smart_size.enabled preference to switch the value from true to false -- this will prevent Firefox from re-increasing the disk cache size

(4) Double-click the browser.cache.disk.capacity preference to display an editing field, and change the value to 400000 (400,000 with no comma) then press Enter/Return or click the blue check mark button to save the change.

I have attached a screenshot sequence of my experiment with these settings.

If that doesn't help, you could experiment with completely disabling disk caching:

(5) Double-click the browser.cache.disk.enable preference to switch the value from true to false -- Firefox may cache more to RAM

Helpful?

more options

Done: -browser.cache.disk.smart_size.enabled ... true to false -browser.cache.disk.capacity ... 491520 to 400000 ... (I guess I'd tried increasing it from 250,000 in the past)

We'll see in a couple of days if this pays off...

I just wish ff managed cache more efficiently!

Helpful?

more options

Hmm, if yours was calculated to be under 500,000 already, perhaps the problem is that removing items takes too long and now it will just happen faster. I guess we'll see.

With smart sizing, mine ends up being a gigabyte, based on having tons of empty disk space.

Helpful?

more options

Couple of days later, still having to clear cache multiple times a day to be able to function. Pages on social media still "bouncing" back to top while browsing.

Plus, none of all my other points have been looked at yet.

Helpful?

more options

I don't know why your cache is not maintaining itself normally. You could try physically removing the folder from your hard drive. These would be the steps for that:

In Firefox, open the About Profiles page by typing or pasting about:profiles in the address bar and pressing Enter/Return to open it.

Find the Profile that has this notation: This is the profile in use and it cannot be deleted. That is your current default profile.

On the "Local Directory" row, click the "Show in Finder", "Open Folder", or "Open Directory" button.

When Finder opens the folder, it may show select the folder name or it may show the folder contents. If you do not see a list of folders including cache2, then double-click the folder name to open it. (cache2 is the folder we want to delete after quitting Firefox.)

Over in Firefox, Quit the program and pause while it shuts down.

Then delete the cache2 folder.

The next time you run Firefox, it should start a fresh cache. Hopefully that one will work more smoothly.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.