Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

want to open webpages from gmail with fire fox

  • 7 replies
  • 1 has this problem
  • 54 views
  • Last reply by jscher2000

more options

When When i Click a link in my Gmail it opens with MS Edge I want it to open with firefox. can someone give me step by step instructions on how to accomplish this. my default browser is Fire fox

Chosen solution

wldproj said

I am not sure what you are asking me but when I launch my Gmail on top is says....

Hi Harvey, how do you launch Gmail? For example:

(A) In Firefox, you go to https://mail.google.com/ , log in to your Google Account, and then view your Inbox in a Firefox tab.

(B) You double-click an icon on your Windows desktop that opens a program other than Firefox, such as the Windows Mail app.

Read this answer in context 👍 0

All Replies (7)

more options

If you are reading your Gmail in a tab in Firefox and you click a normal http:// or https:// link, it definitely should open in Firefox. There isn't any Firefox setting to send regular web page links to other browsers. That said:

If you click a link that leads to a PDF, it might open in a different program depending on your settings for PDFs. See: View PDF files in Firefox or choose another viewer

If you click a link that leads to a file that Firefox can't display, such as .doc/.docx, .xls/.xlsx, and so on, then similar settings determine whether the file is saved, or sent to another application, or Firefox shows a download dialog.

Helpful?

more options

Hello Scher2000 Thanks for your quick reply.

This is the deal. I am opening emails that are in my Gmail account which uses chrome. but this is a manual log in. within my Gmail, if I click onto a URL link it opens in MS Edge This occurs on all links so far as I can see.

What I want is it to open these links in FireFox and I cannot not find any setting in Gmail that sets up default browser, but FireFox & Win 10 are both setup having FireFox as default browser..

I hope I am making my issue clear. What ever info you can offer would be greatly appreciated. Have great day


Harvey

Helpful?

more options

Hi Harvey, I'm not clear on which program you are using to read your Gmail. For example, browsers will generally handles the links opened in that browser:

But other kinds of applications may have their own rules about where links open. Are you using the Windows "Mail" app to read your Gmail? Or Outlook? Or a different Windows app?

Helpful?

more options

I am not sure what you are asking me but when I launch my Gmail on top is says.... Inbox-[email]@gmai.com Gmail and all my emails are displayed when I open one of the emails and if there is a link to a webpage , and I click on that link, that webpage is opened with Microsoft Edge. I would like it to be opened with FireFox

I even went into MS Edge and made sure that it was not set as default and matter of fact this link is opened in MS Edge.

Harvey

Modified by Andrew

Helpful?

more options

Chosen Solution

wldproj said

I am not sure what you are asking me but when I launch my Gmail on top is says....

Hi Harvey, how do you launch Gmail? For example:

(A) In Firefox, you go to https://mail.google.com/ , log in to your Google Account, and then view your Inbox in a Firefox tab.

(B) You double-click an icon on your Windows desktop that opens a program other than Firefox, such as the Windows Mail app.

Helpful?

more options

My email is not opening when I go in on firefox. The address is correct but it doesn't open. The calendar opens but when I go from calendar to email nothing happens. My email opens fine in Chrome. Help!

Helpful?

more options

Hi davidemandelbaum.md.phd, that sounds like a different problem. If you are getting a blank page, please make sure the redirect block is turned off:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste access and pause while the list is filtered

(3) If the accessibility.blockautorefresh preference has a value of true, double-click it to restore the default value of false

More generally: If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) The shield icon toward the left end of the address bar usually turns a bit purplish when content is blocked. Click the icon to learn more or make an exception. See: Enhanced Tracking Protection in Firefox for desktop.

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix usually provide a toolbar button to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you sometimes need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe/Troubleshoot Mode: In this mode, Firefox temporarily deactivates extensions, hardware acceleration, any userChrome.css/userContent.css files, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running:

You can restart Firefox in Safe/Troubleshoot Mode using either:

  • "3-bar" menu button > Help > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)
  • (menu bar) Help menu > Troubleshoot Mode... (before Fx88: Restart with Add-ons Disabled)

and OK the restart. A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

If Firefox is not running:

Hold down the Shift key when starting Firefox. (On Mac, hold down the option/alt key instead of the Shift key.) A small dialog should appear. Click the Open button (before Fx88: "Start in Safe Mode" button).

Note: Don't use the Refresh without first reviewing this article to understand what will be deleted: Refresh Firefox - reset add-ons and settings.

Any improvement?

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.