Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Webpages do not load nor does the option menu

  • 10 replies
  • 1 has this problem
  • 26 views
  • Last reply by jscher2000

more options

Firefox opens with a blank page and does not load any websites. The options menu does not come up either.

Other browsers work fine. Tried troubleshooting by restarting, refreshing, reinstalling, restarting in safe mode, scanning for malware.

Chosen solution

Windows restore worked!

Read this answer in context 👍 0

All Replies (10)

more options

Some problems occur when your Internet security program was set to trust the previous version of Firefox, but no longer recognizes your updated version as trusted. Now how to fix the problem: To allow Firefox to connect to the Internet again;

  • Make sure your Internet security software is up-to-date (i.e. you are running the latest version).
  • Remove Firefox from your program's list of trusted or recognized programs. For detailed instructions, see

Configure firewalls so that Firefox can access the Internet. {web link}

Helpful?

more options

I use windows firewall. I checked this and no luck.

Helpful?

more options

Sometimes there are conflicts between the Malwarebytes Premium anti-exploit feature and Firefox. MBAE would block content processes (the process that handles the content area of the tab). Do you know whether you are using the anti-exploit feature?

Helpful?

more options

This started when I uninstalled McAfee I believe. I didn't use Malwarebytes. However I did just download Malwarebytes to check for malware as part of my troubleshooting.

Helpful?

more options

Hmm, I'm not very familiar with McAfee. Did it leave behind any add-ons in Firefox?

You also could check the connection settings:

  • Windows: "3-bar" menu button (or Tools menu) > Options
  • Mac: "3-bar" menu button (or Firefox menu) > Preferences
  • Linux: "3-bar" menu button (or Edit menu) > Preferences
  • Any system: type or paste about:preferences into the address bar and press Enter/Return to load it

In the search box at the top of the page, type proxy and Firefox should filter to the "Settings" button, which you can click.

The default of "Use system proxy settings" piggybacks on your Windows/IE "LAN" setting. "Auto-detect" can lead to a flaky connection. You may want to try "No proxy".

Any difference?

Helpful?

more options

Somehow my options came up after a reboot and I was able to turn of my proxy. This did not fix anything though.

I also lost my options again. Every time I open firefox it's just a blank screen.

Helpful?

more options

Start your Computer in safe mode with network support. Then start Firefox. Try Secure websites. Is the problem still there?

http://encyclopedia2.thefreedictionary.com/Linux+Safe+Mode Starting Any Computer In Safe Mode; Free Online Encyclopedia

Helpful?

more options

Just tried this. btw this is a win10 machine. I'm thinking of maybe doing a windows restore.

Helpful?

more options

Chosen Solution

Windows restore worked!

Helpful?

more options

I recently got hit with similar symptoms when another program I installed clobbered the VCRuntime files. There's always something new...

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.